BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > M3Forum Garage > Audio/In Car Entertainment (I.C.E.)
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All AlbumsBlogs Garage Search Today's Posts Mark Forums Read Calendar FAQ

Audio/In Car Entertainment (I.C.E.) Place to discuss sights and sounds.


Reply
 
Thread Tools Display Modes
Old Thu, Feb-12-2009, 04:49:58 AM   #1
Got_S54?
Got Lip?
 
Got_S54?'s Avatar
 
Join Date: Mar 2005
Posts: 1,387
Reputation: 0 Got_S54? is on a distinguished road
Location: Bay Area

United States




Default Electronic gremlin problems solved - Icelink is dead

So the other day, I head out to work and was listening to my iPod which is connected to a Dension Icelink that I've had for close to 4 yrs. The prior day, I had installed HID foglights. Anyway, I noticed from the reflection of my car from the car in front of me that one HID foglight wasn't lit, so I toggled the foglight switch a couple of times and then it came on.

Within minutes, the IceLink cut off and switched to radio mode on it's own. This happened a few times in the past (more so before the last firmware update for the IceLink) so I wasn't tripping. Normally, I'd just press the Mode button on my system to get back to Ipod mode and be done with it.

This time, that didn't work. So I turned off the radio and tried to turn it back on, but it wouldn't turn on. The display was dead. Now I'm starting to wonder what's going on. Mind you I'm still driving. So I decide to head back home and do a little bit of trouble shooting. I use my blinkers and noticed the turn signal indicators on my cluster aren't working. Then I try my hazards and they're not working either. Now I'm really starting to worry.

I get back home and am thinking the HID foglights was the last thing I installed so it's got to be that. I pull into the garage, try and roll down my windows but they won't roll down - none of them. Now I'm tripping bad. So I disconnect the HID fog lights, turn the key on and still no good. And now I've discovered too that whenever I turn my key to the ON position, the rear defroster automatically comes on. This was killing me.

To sum up all the gremlins I discovered in the 15 minutes since the trouble started:
1. turn signal indicators on the dash stopped working (although the lights actually do blink)
2. front windows wouldn't roll down / rear windows wouldn't open
3. radio wouldn't turn on / no display on NAV screen
4. rear defroster light comes on automatically every time the car is turned on
5. a relay-clicking type sound whenever I'd depress the clutch

So with the HID fog-lights disconnected and the problem persisting, I check every fuse. All are good. Then I disconnect the battery and leave it off for 30 min. Plug it back in and still, all the problems are there. I'm starting to think I blew a relay or ECU or something that's gonna cost me an arm and a leg and some change.

So WWW to the rescue. Searches on M3Forum and E46Fanatics turn up empty. A Google search for "e46 turn signal indicator radio window" comes up with this result. I'm starting to feel good.

I disconnect the battery, disconnect the IceLink, reconnect the battery and cross my fingers. Lo and behold EVERYTHING is back to normal. So I think perhaps that maybe the IceLink didn't like the HID foglights. So I disconnect the battery again, reconnect the IceLink without the HID foglights (HID fogs are totally disconnected) and bam....all the problems are back. Tried this a total of 3 times and the problem was reproducable every time. But with the IceLink off, everything returns to normal.

I'm bummed that the IceLink is dead, but what I'm really shocked about is the kinds of problems it can introduce to the various on-board electonics - from the instrument cluster, to the windows, to the HVAC controls. Thank goodness that the iBus system wasn't permanently affected.

Hopefully this thread helps other out there solve similar electronic gremlins. It took me 3 days to solve this problem and I'm glad it's over.

On a side note, does anyone know if EAS offers any kind of warranty on the IceLink? I was one of the first batch of Dension IceLink customers from 2005 thanks to Tom. It served me well since I bought it and would like to replace it.
__________________
05 TT 225 Quattro - FK coils|Megan Adj.Cont.Arms|APR catback|15F/20R spacers|OEM ALMS 18's - daily
02 M3 AW/IR - sold but not forgotten

Last edited by Got_S54?; Thu, Feb-12-2009 at 04:53:08 AM.
Jump to top Got_S54? is offline   Reply With Quote
Sponsored Links
Register now and remove these ads
Old Thu, Feb-12-2009, 05:12:40 AM   #2
2euro
APEX KNG
 
2euro's Avatar
 
Join Date: May 2006
Posts: 2,058
Reputation: 0 2euro is on a distinguished road
Location: Bay Area

Philippines




Default

Glad everything turned out ok.

Now it's time to install those HID fogs again..
__________________
Jump to top 2euro is offline   Reply With Quote
Old Tue, Feb-17-2009, 08:39:05 PM   #3
Orange fever
aka yellow fever is now orange fever.
 
Orange fever's Avatar
 
Join Date: Mar 2006
Posts: 5,409
Reputation: 0 Orange fever is on a distinguished road
Location: Da Valley/OC

Thailand




Default

sorry to hear that bro...
HID fogs please.....ftw!!!!
__________________

X5M Black Sapphire / Classic mini '71/
M3 E46 VFE SC Stg3/ M3 E90 SC VF620 EAS/Radenergie/VF-Engineering/ Vorsteiner///
Maintenance/Modings/Detail : SouthBay Autohaus /// Candccollision /// Promobileautodetail ///

March issue of Eurotuner :
http://www.m3forum.net/m3forum/showthread.php?t=252426
Jump to top Orange fever is offline   Reply With Quote
Old Tue, Feb-24-2009, 05:05:05 AM   #4
tom @ eas
M3Forum Sponsor
 
tom @ eas's Avatar
 
Join Date: Aug 2005
Posts: 10,657
Reputation: 0 tom @ eas is on a distinguished road





Default

Unfortunately, Dension doesn't even reside in the US any longer - we have not sold an icelink in over 3 years, yet still support them in Q/A sessions from time to time. DICE has since picked up the slack Dension has left behind, which we fully support.

Your case is due the module failing, shorting ibus and giving erratic commands to the system which other devices seem to be picking up. The module needs to be removed immediately from your M3 before possible damage can occur.
__________________
Tom G. | european auto source (eas)
email: tom@europeanautosource.com web: www.europeanautosource.com tel 866.669.0705 ca: 714.369.8524 x22

GET DAILY UPDATES ON OUR BLOG FACEBOOK YOUTUBE FLICKR INSTAGRAM
Jump to top tom @ eas is offline   Reply With Quote
Old Tue, Feb-24-2009, 05:35:10 AM   #5
Got_S54?
Got Lip?
 
Got_S54?'s Avatar
 
Join Date: Mar 2005
Posts: 1,387
Reputation: 0 Got_S54? is on a distinguished road
Location: Bay Area

United States




Default

Quote:
Originally Posted by tom @ eas View Post
Unfortunately, Dension doesn't even reside in the US any longer - we have not sold an icelink in over 3 years, yet still support them in Q/A sessions from time to time. DICE has since picked up the slack Dension has left behind, which we fully support.

Your case is due the module failing, shorting ibus and giving erratic commands to the system which other devices seem to be picking up. The module needs to be removed immediately from your M3 before possible damage can occur.
Tom, thanks for the reply and explanation. I've removed the IceLink and ordered a Dice from you guys. Looking forward to installing it!
__________________
05 TT 225 Quattro - FK coils|Megan Adj.Cont.Arms|APR catback|15F/20R spacers|OEM ALMS 18's - daily
02 M3 AW/IR - sold but not forgotten
Jump to top Got_S54? is offline   Reply With Quote
Old Thu, Dec-24-2009, 06:02:28 AM   #6
playskool1
NorCal's Valve Adjustment guy
 
playskool1's Avatar
 
Join Date: Mar 2008
Posts: 3,605
In the garage:
Reputation: 0 playskool1 is on a distinguished road
Location: SF Bay Area

United States




Default

i did a search since i started having this problem today. it all started when only one HID fog would turn on so i toggled the foglight switch and both turned on. i noticed that the foglight indicator on the dash did not light up. then when signaled to change lanes the turn indicator did not work for either left or right. i verified that the outside of the car the turn signals do work. the belt buckle light was permanently off. the thing is i dont even have a IceLink. i have the Dice silverline model. i will remove this tomorrow to see if this solves my issue.
__________________

01[LSB][Cinnamon][6 Spd.]ESS VT475
Jump to top playskool1 is offline   Reply With Quote
Old Sun, Dec-27-2009, 04:13:15 PM   #7
lorkar
Ulitimate Fahrmaschine Spezialist
 
lorkar's Avatar
 
Join Date: Mar 2004
Posts: 1,390
Reputation: 0 lorkar is on a distinguished road
Location: Vancouver/ Kootenays

Norway




Default

This is becoming more common as the Dice units are getting older. I bought a used one a few months back and yesturday I was turning left an I noticed my signal light didn't cancel. At the same moment the Ipod stopped working and my radio displayed (Disabled). Pulled over unplugged the dice and it solved the problems. I plugged it back in an hr later an it worked fine for about two hrs and the same problem returned. Thats what I get for buying used. I'll be ordering a new one from EAS in the new year.
__________________
19"SSR GT3s Satin finish,General UHPs, Eisenmann Race Exhaust, Sharked,CSL bumper, CSL diffuser,Depo smoked clears, Authentic ACS rear lip spoiler, Angel eyes.
Jump to top lorkar is offline   Reply With Quote
Old Mon, Dec-28-2009, 04:33:26 PM   #8
tom @ eas
M3Forum Sponsor
 
tom @ eas's Avatar
 
Join Date: Aug 2005
Posts: 10,657
Reputation: 0 tom @ eas is on a distinguished road





Default

Quote:
Originally Posted by lorkar View Post
This is becoming more common as the Dice units are getting older. I bought a used one a few months back and yesturday I was turning left an I noticed my signal light didn't cancel. At the same moment the Ipod stopped working and my radio displayed (Disabled). Pulled over unplugged the dice and it solved the problems. I plugged it back in an hr later an it worked fine for about two hrs and the same problem returned. Thats what I get for buying used. I'll be ordering a new one from EAS in the new year.
This is true on the icelink units, the DICE kits have had 0 ibus issues.

Let me know when ready to order and I'll get everything set up.
__________________
Tom G. | european auto source (eas)
email: tom@europeanautosource.com web: www.europeanautosource.com tel 866.669.0705 ca: 714.369.8524 x22

GET DAILY UPDATES ON OUR BLOG FACEBOOK YOUTUBE FLICKR INSTAGRAM
Jump to top tom @ eas is offline   Reply With Quote
Old Mon, Dec-28-2009, 06:33:01 PM   #9
lorkar
Ulitimate Fahrmaschine Spezialist
 
lorkar's Avatar
 
Join Date: Mar 2004
Posts: 1,390
Reputation: 0 lorkar is on a distinguished road
Location: Vancouver/ Kootenays

Norway




Default

Quote:
Originally Posted by tom @ eas View Post
This is true on the icelink units, the DICE kits have had 0 ibus issues.

Let me know when ready to order and I'll get everything set up.
My bad, I rarely differentiate between the two. Its an ice link.

Well Tom, I have a large wishlist. One question, do you support the retrofit for bluetooth anymore. I don't see it on the website.
__________________
19"SSR GT3s Satin finish,General UHPs, Eisenmann Race Exhaust, Sharked,CSL bumper, CSL diffuser,Depo smoked clears, Authentic ACS rear lip spoiler, Angel eyes.

Last edited by lorkar; Mon, Dec-28-2009 at 06:40:40 PM.
Jump to top lorkar is offline   Reply With Quote
Reply

Bookmarks

Tags
dead, electronic, gremlin, icelink, problems, solved

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical problems resolved---IceLink?? nutz330ci E46 M3 (2001-2006) 23 Sat, Jul-08-2006 03:53:36 AM
Battery dead/drain?V1,icelink drained it? mgt E46 M3 (2001-2006) 2 Sat, Nov-05-2005 07:22:09 PM
Icelink+ with NAV.. any problems or things I should consider? WillC310 Audio/In Car Entertainment (I.C.E.) 12 Fri, Aug-26-2005 04:36:31 PM
IPOD/ICELINK Problems GoodMETHods Faults, Fixes and DIY 10 Fri, Aug-26-2005 02:28:24 AM
iCELink Problems []V[]3 Audio/In Car Entertainment (I.C.E.) 8 Tue, Mar-08-2005 06:18:50 PM



All times are GMT. The time now is 07:22:09 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright 1999-2014 M3Forum.com
Discussing Electronic gremlin problems solved - Icelink is dead in the Audio/In Car Entertainment (I.C.E.) Forum - Place to discuss sights and sounds. at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)