BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > BMW M3 Discussions > E46 M3 (2001-2006)
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All AlbumsBlogs Garage Search Today's Posts Mark Forums Read Calendar FAQ

E46 M3 (2001-2006) Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006.


Reply
 
Thread Tools Display Modes
Old Sun, Nov-30-2008, 03:12:32 PM   #1
FDJon
Registered User
 
FDJon's Avatar
 
Join Date: Jan 2008
Age: 34
Posts: 355
Reputation: 0 FDJon is on a distinguished road
Location: Ingolstadt

Germany




Default Help! car starts, then dies

Guten Tag!

I've tried searching, but it seems everyone else's "start problem" has different symptoms than mine..

Here's my dilemma. After cranking and starting the car, it idles fine for a second, then dies.

I should also note that I am in Berlin on business, and the ball n' chain is caring for the car back in LA, until I ship it over to Germany in a couple months after I get settled in.. Last week the battery died, so she changed it and now I have this problem.

A good friend of mine (retired independent shop owner, worked on Bimmers for decades) is convinced it's either the fuel pump or MAF sensor. I searched on here for problems related to the MAF or fuel pump, but similar problems involve cranking and initial startup- mine starts fine, then dies..

I'm thinking it's the alternator?

Any Ideas from the Gurus? Don E?

Help!!

Vielen Dank!!
__________________
jon

02 LSB 6MT Coupe (sold!)
93 RX7 5MT
07 E86 M Coupe


Last edited by FDJon; Sun, Nov-30-2008 at 03:18:25 PM.
Jump to top FDJon is offline   Reply With Quote
Sponsored Links
Register now and remove these ads
Old Sun, Nov-30-2008, 03:31:59 PM   #2
deilenberger
Moderator
 
deilenberger's Avatar
 
Join Date: Dec 2004
Posts: 13,793
Reputation: 578 deilenberger has a reputation beyond reputedeilenberger has a reputation beyond reputedeilenberger has a reputation beyond reputedeilenberger has a reputation beyond reputedeilenberger has a reputation beyond reputedeilenberger has a reputation beyond repute

United States




Default

I would tend to agree with your friend.. although the reason for it being the fuel pump may not be so obvious.

If the M3 system works like other BMW systems do - the pump is powered up when the starter is activated, and the power to it only remains on after the engine is started and running. If the engine doesn't start, or the engine stalls for some reason the system is supposed to turn the pump off.

It sounds as if the ECU isn't seeing the "keep-running" signal. It powers up the pump during cranking for long enough to have the engine start for a moment - but then shuts the pump down thinking the engine isn't running. As the pressure in the system drops - the engine dies.

So - what to do? Someone has to listen to the pump and try to hear if this is what's happening. Runs during startup, then shuts down and the engine stalls.

If that's the case - I'd suggest checking all the fuses (it's possible the two circuits/functions are seperately fused). If there is nothing obvious - it may be time to call in a pro who can monitor engine sensors in real time. If I had to guess - it might be the crankshaft sensor that provides the keep-alive signal.. but that's strictly a WAG.

The MAF could be checked by simply unplugging it - the ECU will go into a default map mode and the engine should run. I'm doubtful that it's the MAF, but easy to test.
__________________
Don Eilenberger AKA bellymeisterburgermeister and denilegiiiiiiiiiiiiibennnnegerieragher (but that's misspelled..)
  • 2001 M-Coupe - TiSilver/Black - Das Boot..
  • 2002 M3C/6 - Imola Red/Black - SOLD
  • 2003 525iT - Green/Tan - SOLD - replaced with Lexus
  • 2006 Cayenne/S - Iceland Silver Metallic/Stone-steel Gray - Truckster.
  • 2007 R1200R - Roadster, black mit/white pinstripes - the REAL BMW..
  • 2011 Lexus RX-350. SWMBO's new toy.
Jump to top deilenberger is offline   Reply With Quote
Old Sun, Nov-30-2008, 03:49:53 PM   #3
FDJon
Registered User
 
FDJon's Avatar
 
Join Date: Jan 2008
Age: 34
Posts: 355
Reputation: 0 FDJon is on a distinguished road
Location: Ingolstadt

Germany




Default

That was quick. damn.

Thanks for the advice, Don- I was hoping you'd see my bat-signal! haha.

Interestingly, my friend said the exact same thing about unplugging the MAF to rule that out...

Does this seem to be a common s54 problem? I've never heard of this from anyone else..
__________________
jon

02 LSB 6MT Coupe (sold!)
93 RX7 5MT
07 E86 M Coupe

Jump to top FDJon is offline   Reply With Quote
Old Sun, Nov-30-2008, 04:00:49 PM   #4
deilenberger
Moderator
 
deilenberger's Avatar
 
Join Date: Dec 2004
Posts: 13,793
Reputation: 578 deilenberger has a reputation beyond reputedeilenberger has a reputation beyond reputedeilenberger has a reputation beyond reputedeilenberger has a reputation beyond reputedeilenberger has a reputation beyond reputedeilenberger has a reputation beyond repute

United States




Default

Two questions - I see the battery was replaced. Why? And has it run at all since the battery replacement?
__________________
Don Eilenberger AKA bellymeisterburgermeister and denilegiiiiiiiiiiiiibennnnegerieragher (but that's misspelled..)
  • 2001 M-Coupe - TiSilver/Black - Das Boot..
  • 2002 M3C/6 - Imola Red/Black - SOLD
  • 2003 525iT - Green/Tan - SOLD - replaced with Lexus
  • 2006 Cayenne/S - Iceland Silver Metallic/Stone-steel Gray - Truckster.
  • 2007 R1200R - Roadster, black mit/white pinstripes - the REAL BMW..
  • 2011 Lexus RX-350. SWMBO's new toy.
Jump to top deilenberger is offline   Reply With Quote
Old Sun, Nov-30-2008, 05:38:14 PM   #5
FDJon
Registered User
 
FDJon's Avatar
 
Join Date: Jan 2008
Age: 34
Posts: 355
Reputation: 0 FDJon is on a distinguished road
Location: Ingolstadt

Germany




Default

1. The battery hadn't been replaced since new (6 years), and it finally died and had to be jumped 3 times during the past week.

2. Apparently the car hasn't run at all since the battery replacement. Even while still connected to the jumper car with the old battery, it would start then die- which leads me to think it may not be the battery?
__________________
jon

02 LSB 6MT Coupe (sold!)
93 RX7 5MT
07 E86 M Coupe


Last edited by FDJon; Sun, Nov-30-2008 at 05:42:17 PM.
Jump to top FDJon is offline   Reply With Quote
Old Sun, Nov-30-2008, 06:22:49 PM   #6
deilenberger
Moderator
 
deilenberger's Avatar
 
Join Date: Dec 2004
Posts: 13,793
Reputation: 578 deilenberger has a reputation beyond reputedeilenberger has a reputation beyond reputedeilenberger has a reputation beyond reputedeilenberger has a reputation beyond reputedeilenberger has a reputation beyond reputedeilenberger has a reputation beyond repute

United States




Default

Ah - not a good thing.

Jumping a car always has the risk of causing other damage to the electronics in the car. I'm gonna guess this is what happened.

The spark you see when you connect the jumper cables causes an inductive high-voltage spike in the car's electrical system that can damage electronic components. It's recommended that when connecting a car for jumping - heavy load devices be turned ON (oddly enough) to help absorb the spike (things like the headlights, the rear-window defroster) before doing the connection.

At this point - I'd guess it has to be flatbedded to a dealer who will be able to tell more when it's hooked up to diagnostics.

Good luck..
__________________
Don Eilenberger AKA bellymeisterburgermeister and denilegiiiiiiiiiiiiibennnnegerieragher (but that's misspelled..)
  • 2001 M-Coupe - TiSilver/Black - Das Boot..
  • 2002 M3C/6 - Imola Red/Black - SOLD
  • 2003 525iT - Green/Tan - SOLD - replaced with Lexus
  • 2006 Cayenne/S - Iceland Silver Metallic/Stone-steel Gray - Truckster.
  • 2007 R1200R - Roadster, black mit/white pinstripes - the REAL BMW..
  • 2011 Lexus RX-350. SWMBO's new toy.
Jump to top deilenberger is offline   Reply With Quote
Old Tue, Dec-02-2008, 08:50:45 PM   #7
FDJon
Registered User
 
FDJon's Avatar
 
Join Date: Jan 2008
Age: 34
Posts: 355
Reputation: 0 FDJon is on a distinguished road
Location: Ingolstadt

Germany




Default

update-

1. checked the MAF by unplugging it- car still dies. Maf ruled out.

2. Fuel pump runs for a couple seconds after car dies, then shuts off. Fuel pump also ruled out.

Next step is to flatbed it to a shop- heard anything of Marina BMW Motors in Marina Del Rey, CA? Or is it necessary to bring it to the stealer?

Uh oh.
__________________
jon

02 LSB 6MT Coupe (sold!)
93 RX7 5MT
07 E86 M Coupe

Jump to top FDJon is offline   Reply With Quote
Old Tue, Dec-02-2008, 08:51:23 PM   #8
FDJon
Registered User
 
FDJon's Avatar
 
Join Date: Jan 2008
Age: 34
Posts: 355
Reputation: 0 FDJon is on a distinguished road
Location: Ingolstadt

Germany




Default

Updates will be posted...
__________________
jon

02 LSB 6MT Coupe (sold!)
93 RX7 5MT
07 E86 M Coupe

Jump to top FDJon is offline   Reply With Quote
Old Tue, Dec-02-2008, 08:53:37 PM   #9
FDJon
Registered User
 
FDJon's Avatar
 
Join Date: Jan 2008
Age: 34
Posts: 355
Reputation: 0 FDJon is on a distinguished road
Location: Ingolstadt

Germany




Default

..and still haven't checked the fuses yet, either. That, then the shop.
__________________
jon

02 LSB 6MT Coupe (sold!)
93 RX7 5MT
07 E86 M Coupe

Jump to top FDJon is offline   Reply With Quote
Old Tue, Dec-02-2008, 09:37:37 PM   #10
FDJon
Registered User
 
FDJon's Avatar
 
Join Date: Jan 2008
Age: 34
Posts: 355
Reputation: 0 FDJon is on a distinguished road
Location: Ingolstadt

Germany




Default

maybe just to be 110% sure- i'd like to swap out the MAF with someone else's to be completely sure?

Anyone in LA (venice area) wanna help out?
__________________
jon

02 LSB 6MT Coupe (sold!)
93 RX7 5MT
07 E86 M Coupe

Jump to top FDJon is offline   Reply With Quote
Reply

Bookmarks

Tags
car, dies, starts

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Please help: car dies while driving! shardm3 E46 M3 (2001-2006) 3 Tue, Aug-26-2008 05:49:38 AM
2002 M3 Starts then dies 1 second later. Hybred Faults, Fixes and DIY 1 Wed, Jan-09-2008 07:21:44 PM
a/c? car almost dies....... Bliz33 E46 M3 (2001-2006) 0 Sat, Feb-03-2007 07:07:47 AM
car dies out of park pmexaminer Faults, Fixes and DIY 1 Tue, Sep-20-2005 07:51:31 PM
Car Dies 3 Days After Purchase! tb151 E46 M3 (2001-2006) 12 Mon, Sep-22-2003 07:32:27 PM



All times are GMT. The time now is 11:09:07 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright 1999-2014 M3Forum.com
Discussing Help! car starts, then dies in the E46 M3 (2001-2006) Forum - Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006. at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)