BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > BMW M3 Discussions > E46 M3 (2001-2006)
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All Albums Garage Search Today's Posts Mark Forums Read Calendar FAQ

E46 M3 (2001-2006) Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006.


Reply
 
Thread Tools Display Modes
Old Wed, Jun-22-2016, 02:42:08 AM   #31
graydon
Registered User
 
graydon's Avatar
 
Join Date: Aug 2002
Age: 53
Posts: 19
In the garage:
Reputation: 0 graydon is on a distinguished road
Location: Fenton, MI

United States




Default Re: What is the "EML" yellow light on the instrument?

Quote:
Originally Posted by EUROFEST View Post
I'm starting to get frustrated! So far I have replaced the following parts and still experiencing the EML "limp" problem...

1) TPS - front one
2) TPS - under manifold
3) TPS - throttle pedal assembly actually
4) Throttle actuator motor - under manifold
5) Fuel pump - in tank

Only thing left to do is fuel filter and/or regulator.
Did the fuel filter 2yrs ago, so I can't see it being that.
I'm almost at my wits end! I'll post the solution (if/when I find it).

I know going to CSL/map tune makes the system much more sensitive with lack of MAF, but this is ridiculous.
I did all of these as well last fall on my '05 ZCP w/ SMG. It turned out that the actuator was at fault so I re-installed the original pedal and front TPS back into the car. It came back a few weeks ago so I swapped in the new front TPS but that did not fix it. Then I swapped in the new pedal and that also did not fix it. So, I removed the intake last Friday night and cleaned everything, lubed all of the throttle and jack shaft pivots and replaced the O-rings on the idle air tubes. None of these things fixed the issue but I did notice that the actuator responded by trying to close the throttles when I pushed down on the link to the jack shaft and that got me thinking. Last night I removed the screws on the front TPS and started the car. Then I slowly rotated the TPS while the engine idled. Sure enough, as I moved it one way the engine stuttered and died. When I moved it the opposite direction (clockwise), the idle smoothened out.

So, I put the screws back in and snugged them slightly. Then I rotated the TPS as much as it would go with the screws in. Maybe it turned a tenth of a degree, but I turned it tight against the sides of the screws and then tightened those screws down tight. Since then I have driven to Meijer and back and today I drove to work and back, about 45 miles each way with a combination of freeway and city driving. In the last few days I could not go more than a couple hundred yards without having to shut off and restart the car to reset the EML light and many times it absolutely would not reset. Since the TPS "adjustment" the EML light has not come on now in the last day and a half. It has not stuttered or stumbled even once which indicates to me that the TPS is now much closer to being in sync with the actuator TPS.

I hope this can help someone. I was getting frustrated with my car. It is so much fun to drive but it is so frustrating when you can only drive it in limp-home mode.
__________________
Sincerely,
Graydon Stuckey
2005 M3 ZCP
Jump to top graydon is offline   Reply With Quote
Sponsored Links
Register now and remove these ads
Old Wed, Jun-22-2016, 01:58:28 PM   #32
Cuz5150
Cuz5150
 
Cuz5150's Avatar
 
Join Date: May 2011
Posts: 528
Reputation: 0 Cuz5150 is on a distinguished road
Location: S. NJ

United States




Default Re: What is the "EML" yellow light on the instrument?

Quote:
Originally Posted by Schnout View Post
Old post, but current response. I solved this problem with my 2004 E46 vert.

EML + Brake Light + DSC = TOTAL LIMP MODE.

Temporary fix...shut off the car. Restart...don't do what you did just before going into limp mode.

For me...the permanent fix was replacing the "front" Throttle Position Sensor (TPS) (located directly adjacent to the oil filter); (Part number 13-63-7-840-383). $50 at any of a number of online suppliers.

I "dealt with" this problem for about a year; just making sure not to accelerate too much Who the hell wants to drive an M3 like that???

The reason I dealt with it was that nowhere could I find a definitive solution for the problem. FINALLY...I just decided "WHAT THE HECK. THE CAR IS 12 YEARS OLD...AND...IT'S ONLY 50 BUCKS. CAN'T HURT TO PUT IN A NEW TPS."

So...I spent literally less than 10 minutes to replace the front TPS. When I took out the old one, the rotational "switch"/sensor mechanism (which is connected to the end of the throttle control rod causing the sensor internals to rotate inside its housing) was "sloppy" - jiggling around inside the TPS housing. Clearly this sensor had been mechanically worn through probably MILLIONS of rotational cycles.

I put in the new TPS and HOLY CRAP WOW!!!

Let's not even talk about solving the EML/Limp problem...the IMMEDIATE RESPONSE IN INCREASED POWER...INCREASED THROTTLE RESPONSE...NIMBLENESS...

I've driven this car for SEVEN YEARS...AND NEVER FELT IT RUN LIKE THIS!!!

For years, I'd been wanting to run the Suchez Loop (North Georgia mountains), but never dared...because of the EML problem.

Well...just this week, I ran it with my Porsche 944 buddy...who runs it all the time...In spite of his 800 pound lighter vehicle, his driving experience, and his familiarity with the road (which I have never even seen); I was almost nearly able to stay on his tail most of the way...except in the tightest serpentine sections...but...I was close...and thanks to the new TPS...I was able to regain much of the distance in the (very short and very brief) straight sections.

and...we ain't talking about any "GRANNY DRIVING" here boys & girls...

It was ONE VERY SERIOUS RUN...hitting speeds of 100mph+ for brief moments...just before braking into the turns...over and over again...

Let's just say that my oil temp was quite high when we were done

MORAL OF THE STORY...If you ain't changed out your TPS (there are two of them - identical P/N - one on each end of the throttle system), and your car is "old enough" to have cycled these sensors a few million times...

CHANGE THEM NOW!!! REGARDLESS OF WHETHER OR NOT YOU ARE EXPERIENCING EML PROBLEM (YET).

I bought two...and fortunately the easy one solved "THE PROBLEM," but now I am going to install the second one, which is evidently below the intake manifold...a bit tougher to get to...but it's gonna be WELL WORTH the small extra effort.
The past two weeks my 04 Vert is doing the same thing
Im reading this thread but not sure what witch TPS to tackle first
__________________
http://im1.shutterfly.com/media/47a3cc29b3127ccef48539c87df200000030O00AaNHDJi0YuG  IPbz4a/cC/f%3D0/ls%3D00108141284420131209001350520.JPG/ps%3D50/r%3D0/rx%3D550/ry%3D400/
2007 Z4 Coupe/Black/Black/6mt/Premium/Xenon
2004/M3/Vert/Black/Imola/6mt/Cold/Xenon/HK
2006/M3/Coupe/Mystic/Black/6mt/ZCP/Xenon/HK
2009/135i/Coupe/Alpine/Black/6mt/M-sport/Idrive-sold
2002 998 Ducati-sold
-Diplomacy is saying "nice doggie" while trying to find a rock
Jump to top Cuz5150 is offline   Reply With Quote
Old Thu, Jun-23-2016, 02:55:28 PM   #33
EUROFEST
Registered User
 
Join Date: Sep 2009
Posts: 105
In the garage:
Reputation: 0 EUROFEST is on a distinguished road
Location: Mrs. Sauga

Canada




Default Re: What is the "EML" yellow light on the instrument?

Since i'm running a CSL airbox and CSL (map) tune, I thought my (newly found) valve cover gasket leak may be a factor to EML light since it throws off the amount of vacuum in the rail. Changed the valve cover gasket last night.. no help.

I think I may have found my issue.. i've noticed that the EML light only goes on when driven a lower speeds (in the city) and when the engine is hot (oil temps at 210F). My IAT sensor is currently in the stock Evolve location and they are registering crazy high (160F) at idle. Just before the EML light trips, the car stumbles and my AFR gauge shows very rich momentarily. All these symptoms leads me to believe I should relocate the IAT sensor to a better location to what Evolve designed. Going to mock up a bracket tomorrow at work and try it. Will update this thread Saturday.
__________________
Randy Sparre aka EMPOWERD
-993 GT2 (original 1 of 189)
-'02 M3 SMG (steel grey/cinn)
-'07 335i Cab (space grey/blk)


2002 BMW M3 SMG, Matte Metallic Purple Wrap on Cinnamon
ENGINE: Schrick 288/280 cams | Head decked/ported/polished | Evolve CSL box | MarkD CSL map tune
EXHAUST/DRIVETRAIN: Headers | 200cell midpipes | Agency Power V1 Muffler | 4.10 Differential
SUSPENSION/CHASSIS: Hotbits DT1 coilovers | TMS Sway Bars | Adj. end links | GC RSMs | Powerflex RTABS | TMS subframe reinforcement
WHEELS/TIRES: BCForged HB29, 19x9.5" & 11" | RE760- 235/275
BRAKES: (4) WPpro 6-pots | Sawblade discs | Steel Braided thoughout
EXTERIOR: Avery Wrap | CSL Trunklid | Hamann splitter | ACS roof spoiler | blacked-out trim theme
INTERIOR: Cinnamon interior swap | Raven 6-pnt cage | Kenwood KIV BT900 | DLS components/A7 amp/12" sub | Schroth harness | Billet F1 paddles
Jump to top EUROFEST is offline   Reply With Quote
Old Thu, Jun-23-2016, 04:58:30 PM   #34
Cuz5150
Cuz5150
 
Cuz5150's Avatar
 
Join Date: May 2011
Posts: 528
Reputation: 0 Cuz5150 is on a distinguished road
Location: S. NJ

United States




Default Re: What is the "EML" yellow light on the instrument?

I have solved this issue i believe. Yesterday, i got a chance to stop by my BMW specialist to retrieve codes in order to have a shot at this.
Well, 3 codes were pulled in my case, 230,120,118. My specialist said no way this car should have issues do to the mileage 35K. He used the scanner to do a adaptation/reset? of TPS sensor. He pressed the gas pedal 3 times....etc.

He also asked me if i ever had started the car or turned the key ON, with this TPS unplugged. Hmmmm, the answer is yes, it has happen 3 times over the past couple of years. When i do an oil change, i forget to plug it back in.
Moral of my story is have someone with a scanner do an adaptation/reset of the TPS's. before u go replacing sensors...
Have been driving the car yesterday, last night and this morning.
No EML-CEL-DSC-BRAKE lights Hope this helps the m3forum community
__________________
http://im1.shutterfly.com/media/47a3cc29b3127ccef48539c87df200000030O00AaNHDJi0YuG  IPbz4a/cC/f%3D0/ls%3D00108141284420131209001350520.JPG/ps%3D50/r%3D0/rx%3D550/ry%3D400/
2007 Z4 Coupe/Black/Black/6mt/Premium/Xenon
2004/M3/Vert/Black/Imola/6mt/Cold/Xenon/HK
2006/M3/Coupe/Mystic/Black/6mt/ZCP/Xenon/HK
2009/135i/Coupe/Alpine/Black/6mt/M-sport/Idrive-sold
2002 998 Ducati-sold
-Diplomacy is saying "nice doggie" while trying to find a rock
Jump to top Cuz5150 is offline   Reply With Quote
Old Fri, Jul-01-2016, 02:25:23 AM   #35
Audigy
Registered User
 
Audigy's Avatar
 
Join Date: Jul 2006
Posts: 496
In the garage:
Reputation: 0 Audigy is on a distinguished road
Location: Edmonton

Canada




Default Re: What is the "EML" yellow light on the instrument?

*UPDATE*
To whomever read my post last page. It was the front TPS sensor that needed replacing. Thankful since it was the easiest part to replace out of the potential 4 it could have been. Annoyed that it failed in the first place. I did spray the engine bay down with a garden hose (alternator covered of course) 2 days before. Other than that not sure why it failed.
I also found I had to do a smg reset as it was very sluggish in terms of shifting on setting 5 which I typically have it on.
Hope this helps the community with a future EML light issue.
__________________



2006 IB ZCP SMG
Jump to top Audigy is offline   Reply With Quote
Old Fri, Jul-01-2016, 05:16:29 AM   #36
terraphantm
Moderator
 
Join Date: Dec 2010
Posts: 11,049
In the garage:
Reputation: 11 terraphantm is on a distinguished road
Location: Philadelphia

United States




Default Re: What is the "EML" yellow light on the instrument?

Quote:
Originally Posted by Audigy View Post
*UPDATE*
To whomever read my post last page. It was the front TPS sensor that needed replacing. Thankful since it was the easiest part to replace out of the potential 4 it could have been. Annoyed that it failed in the first place. I did spray the engine bay down with a garden hose (alternator covered of course) 2 days before. Other than that not sure why it failed.
I also found I had to do a smg reset as it was very sluggish in terms of shifting on setting 5 which I typically have it on.
Hope this helps the community with a future EML light issue.
That one seems to fail most frequently in my experience. Probably heat related. So far I've had to replace one a year since owning the car.

I've been meaning to look into replacing it with a hall effect TPS so that it can't really wear out.
__________________
Jump to top terraphantm is offline   Reply With Quote
Old Wed, Jul-13-2016, 10:05:55 PM   #37
BMW m3 vert
2003 BMW m3 vert
 
Join Date: Jul 2016
Posts: 1
In the garage:
Reputation: 0 BMW m3 vert is on a distinguished road
Location: Plantagenet,ON

Canada




Thumbs up Re: What is the "EML" yellow light on the instrument?

I just joined this site as when I googled the EML light it came to this BMW site, so I wanted to try and help out other BMW owners.
I drove 5 hrs on Sunday and just as I was exiting the highway my yellow EML light came on. Sitting at the light noticed a total drop in power. Car wouldn't rev as normal. Seemed to be in a "limp mode".
Got to my hotel and when I started the car light was out and no issues. Car drove fine for the next 3 days. So light came back on today. Read the post on here and took it to a dealer able to do a scan of the codes. Turns out they say its the TPS sensor, or gas pedal sensor. It'll be in tomorrow and a few hundred bucks with the diagnostics and I'll be golden. Thanks to you guys on here for getting me the correct info. I knew there were 2 sensors after reading your posts but the codes pulled says TPS.
Hope this helps someone else someday.
Jump to top BMW m3 vert is offline   Reply With Quote
Old Tue, Oct-18-2016, 05:03:35 AM   #38
MarkD
Registered User
 
Join Date: Mar 2011
Posts: 6
Reputation: 0 MarkD is on a distinguished road
Location: Toronto

Canada




Default Re: What is the "EML" yellow light on the instrument?

Quote:
Originally Posted by Cuz5150 View Post
I have solved this issue i believe. Yesterday, i got a chance to stop by my BMW specialist to retrieve codes in order to have a shot at this.
Well, 3 codes were pulled in my case, 230,120,118. My specialist said no way this car should have issues do to the mileage 35K. He used the scanner to do a adaptation/reset? of TPS sensor. He pressed the gas pedal 3 times....etc.

He also asked me if i ever had started the car or turned the key ON, with this TPS unplugged. Hmmmm, the answer is yes, it has happen 3 times over the past couple of years. When i do an oil change, i forget to plug it back in.
Moral of my story is have someone with a scanner do an adaptation/reset of the TPS's. before u go replacing sensors...
Have been driving the car yesterday, last night and this morning.
No EML-CEL-DSC-BRAKE lights Hope this helps the m3forum community
Hi Cuz5150,

has your problem returned after the TPS adaptation?

MarkD
Jump to top MarkD is offline   Reply With Quote
Old Sat, Oct-22-2016, 06:35:44 PM   #39
asmaa
Banned
 
Join Date: Oct 2016
Posts: 3
Reputation: 0 asmaa is on a distinguished road

United States




Default Re: What is the "EML" yellow light on the instrument?

Very nice!
Jump to top asmaa is offline   Reply With Quote
Reply

Bookmarks

Tags
eml, instrument, light, yellow

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: Brembo Front BBK in "Fly" Yellow w/ 15" 380mm rotors double_R Parts for Sale/Wanted 13 Tue, May-20-2008 06:55:43 PM
POLL: getting a DUCATI 1098.... "RED" or "YELLOW" ??? jimmy540i.com Off Topic 31 Sun, Aug-26-2007 03:15:57 AM
dreading "yellow" oil change light.... 2euro E46 M3 (2001-2006) 16 Wed, Sep-06-2006 05:13:29 PM
Yellow Oil "idiot light" came on today winternj E46 M3 (2001-2006) 8 Mon, Jul-25-2005 03:03:57 AM



All times are GMT. The time now is 06:52:14 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright 1999-2017 M3Forum.com
Discussing What is the "EML" yellow light on the instrument? in the E46 M3 (2001-2006) Forum - Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006. at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)