BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > M3Forum Garage > Faults, Fixes and DIY
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All Albums Garage Search Today's Posts Mark Forums Read Calendar FAQ

Faults, Fixes and DIY Please share your experience and knowledge with other members by contributing your own DIY, or by helping another member find the elusive fix!


Reply
 
Thread Tools Display Modes
Old Mon, May-21-2018, 01:20:34 AM   #1
PashkaVR
Registered User
 
Join Date: Jun 2013
Posts: 12
Reputation: 0 PashkaVR is on a distinguished road

United States




Default Solution: misfires at no load.

Hey all, I just spent a bunch of time trying to figure out a misfire that seems to be common and finally figured it out. I replaced plugs, O2s (they were wonky), swapped coils, adjusted the valves, and did all the usual bits with no luck.

Problem: light skip at idle only with no load, car runs perfect otherwise.

Mechanical problem: As the throttle bodies get dirty and the stops wear a bit, the idle control valve pumps more air in to compensate for the lack of flow through the throttles. Because of where the idle valve dumps the air, cylinder 4 was having lean misfires because so much volume was coming in there.

Solution: Clean the throttle bodies and (if you absolutely have to!) adjust the end stops on the throttles. The idle valve will have to flow less air and each cylinder will have a much more uniform amount of air coming in.

Hope this helps other people, I think as the S54s are coming into the higher mileage range more people may encounter this and will likely spend a lot of money replacing coils and such.
__________________
Daytona Violett M S54
Volvo 240 V8
IG PashkaVR6
Jump to top PashkaVR is offline   Reply With Quote
Sponsored Links
Register now and remove these ads
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 01:26:57 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright 1999-2017 M3Forum.com
Discussing Solution: misfires at no load. in the Faults, Fixes and DIY Forum - Please share your experience and knowledge with other members by contributing your own DIY, or by helping another member find the elusive fix! at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)