BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > BMW M3 Discussions > E36 M3 (1992-1999)
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All Albums Garage Search Today's Posts Mark Forums Read Calendar FAQ

E36 M3 (1992-1999) {Euro - S50 B32 321hp @ 7400 rpm} {U.S. - S52 B32 240 hp @ 6000 rpm}
Total Produced: 71,212 - Years Produced: 1992 to 1999


Reply
 
Thread Tools Display Modes
Old Mon, Jun-19-2017, 01:58:35 AM   #1
DasBlitzAuto
Registered User
 
Join Date: Apr 2017
Posts: 25
Reputation: 0 DasBlitzAuto is on a distinguished road
Location: Long Island

United States




Default Oil Pressure Light with Liqui Moly at Track

Hey guys I'm very sorry to post another one of these but I couldn't find anything very recent about this last post i saw that was useful at all was back in 2009.

Anyhow I recently bought a 97 M3 as a track car it has 104k on the clock. This past weekend I was running at NJMP and noticed by oil pressure light flickering at idle after a session, as well as lifter tick. I tapped the gas a little light goes away. Then I can turn it off and start it back up a few mins later no lights no ticking. Im running Liqui Moly 5w40 the outside temps were 84 degrees Water temp was @ 214.

I know this can be normal on these cars but I just figured I'd ask if I should be running heavier oil for the track or if anyone else has these issues with the Liqui Moly oil.

Thanks in Advance!!!
__________________
1997 Estorilblau E36 M3
TCKR Suspension - Turner Sways - Active Autowerke Intake/Exhaust - 17x9 ARC8 - Hankook RS4 245/40/17 Square - UUC EVO Short Shifter

Last edited by DasBlitzAuto; Mon, Jun-19-2017 at 02:12:38 AM.
Jump to top DasBlitzAuto is offline   Reply With Quote
Sponsored Links
Register now and remove these ads
Old Mon, Jun-19-2017, 03:43:08 AM   #2
deboM3
Registered User
 
Join Date: Jun 2006
Posts: 57
Reputation: 0 deboM3 is on a distinguished road





Default Re: Oil Pressure Light with Liqui Moly at Track

I had a similar issue with 5w30. I switched to 15w50 and havnt seen the light since! I believe it's due to worn bearing clearances and the thinner oil doesn't keep the pressure up when the temp increases. Mine would only flicker at idle on super hot days and driving hard. I've driven probably 100k since I had the issue after switching oil so I wouldn't panic or anything.
Jump to top deboM3 is offline   Reply With Quote
Old Mon, Jun-19-2017, 04:18:09 AM   #3
mewantkouki
Registered User
 
Join Date: Aug 2011
Posts: 61
Reputation: 0 mewantkouki is on a distinguished road

United States




Default Re: Oil Pressure Light with Liqui Moly at Track

My car had the flicker when I got it. I changed out the oil pressure switch and I haven't had any issues since. Hopefully it's something simple. The best way to get an idea of what's really going on in the oiling system would be with an aftermarket gauge.
Jump to top mewantkouki is offline   Reply With Quote
Old Mon, Jun-19-2017, 04:41:16 AM   #4
deboM3
Registered User
 
Join Date: Jun 2006
Posts: 57
Reputation: 0 deboM3 is on a distinguished road





Default Re: Oil Pressure Light with Liqui Moly at Track

Quote:
Originally Posted by mewantkouki View Post
My car had the flicker when I got it. I changed out the oil pressure switch and I haven't had any issues since. Hopefully it's something simple. The best way to get an idea of what's really going on in the oiling system would be with an aftermarket gauge.
Second this! Forgot to mention my oil pressure was around 5-7 Psig when the light was flickering measured on an electronic vdo gauge. Since switching oils it's around 10 always, even when it's Uber hot and after driving hard.
Jump to top deboM3 is offline   Reply With Quote
Old Mon, Jun-19-2017, 06:08:02 AM   #5
in4lee
Registered User
 
Join Date: Jul 2015
Posts: 16
In the garage:
Reputation: 0 in4lee is on a distinguished road

United States




Default Re: Oil Pressure Light with Liqui Moly at Track

I run 15w-50 and have the same issue. However I replaced the oil pressure switch and the issue remains. Next thing might be a crack in the oil pick up tube which can be replaced with the z3 one offering more reinforcement.
Jump to top in4lee is offline   Reply With Quote
Old Mon, Jun-19-2017, 07:25:59 PM   #6
DasBlitzAuto
Registered User
 
Join Date: Apr 2017
Posts: 25
Reputation: 0 DasBlitzAuto is on a distinguished road
Location: Long Island

United States




Default Re: Oil Pressure Light with Liqui Moly at Track

Thanks for the replies guys!! Would you say Mobil 1 would be a good choice to throw some 15w-50 in there?

Ill also look into getting a gauge and replacing the switch.


Thanks again guys!!!
__________________
1997 Estorilblau E36 M3
TCKR Suspension - Turner Sways - Active Autowerke Intake/Exhaust - 17x9 ARC8 - Hankook RS4 245/40/17 Square - UUC EVO Short Shifter
Jump to top DasBlitzAuto is offline   Reply With Quote
Old Mon, Jun-19-2017, 08:20:41 PM   #7
Nate047
Registered User
 
Nate047's Avatar
 
Join Date: May 2016
Posts: 614
In the garage:
Reputation: 0 Nate047 is on a distinguished road
Location: Los Angeles

United States




Default Re: Oil Pressure Light with Liqui Moly at Track

I have had a similar issue. Only occurs when the motor is fully warm and if the oil level is slightly low. Previous owners put 5w30 in the car it's whole life, I bought the car with about 122,xxx miles. I replaced the pressure sender, oil pump, pick up tube, added 15w40 Liqui Moly and still had the problem. Went to 15w50 on my last oil change and have not yet seen the light flicker. Did a Blackstone Labs analysis, shows low likelihood of worn bearings. If the light shows up again, the oil filter housing is the last thing I'll replace before looking at rod bearings.
__________________
http://www.natehasslerphoto.com
Jump to top Nate047 is offline   Reply With Quote
Old Tue, Jun-20-2017, 01:11:00 AM   #8
DasBlitzAuto
Registered User
 
Join Date: Apr 2017
Posts: 25
Reputation: 0 DasBlitzAuto is on a distinguished road
Location: Long Island

United States




Default Re: Oil Pressure Light with Liqui Moly at Track

Quote:
Originally Posted by Nate047 View Post
I have had a similar issue. Only occurs when the motor is fully warm and if the oil level is slightly low. Previous owners put 5w30 in the car it's whole life, I bought the car with about 122,xxx miles. I replaced the pressure sender, oil pump, pick up tube, added 15w40 Liqui Moly and still had the problem. Went to 15w50 on my last oil change and have not yet seen the light flicker. Did a Blackstone Labs analysis, shows low likelihood of worn bearings. If the light shows up again, the oil filter housing is the last thing I'll replace before looking at rod bearings.
Seems like 15w-50 is the way to go first then. Ill go pick some up and I guess Ill see what happens at the next HPDE.
__________________
1997 Estorilblau E36 M3
TCKR Suspension - Turner Sways - Active Autowerke Intake/Exhaust - 17x9 ARC8 - Hankook RS4 245/40/17 Square - UUC EVO Short Shifter
Jump to top DasBlitzAuto is offline   Reply With Quote
Old Tue, Jun-20-2017, 02:30:31 PM   #9
kyrix1st
Registered User
 
kyrix1st's Avatar
 
Join Date: May 2016
Posts: 293
In the garage:
Reputation: 0 kyrix1st is on a distinguished road
Location: Kyoto

Japan




Default Re: Oil Pressure Light with Liqui Moly at Track

I don't know much about US spec M3s, but it could be the following:

1. Oil pressure sensor malfunction: It has to hit 0.8 bar or so for the light to flicker. High chance.

2. Oil pump failure: Not complete, but weak.

3. Oil pressure relief valve not closing: Typically happens at high rpm but not at idle.

4. bearing clearance: Will also drink your oil since it gets through the valve.

5. Oil shearing: Unlikely, but if you use crappy group II oil or regular group III oil at the track, this will happen. I used shell ultra helix 5w-40 before, and after 30 laps the engine started to make ticking noise. Changed to redline 5w-40 (group IV&V); I have no engine noise and no viscosity change after 4,000km of hard driving.
__________________
WTB: Carbon airbox



Car history: E85 Z4 3.0i smg//Current: 98' E36 M3 evo
Current setup:Bilstein clubsport coilover// E46 M3 front Brembo 4P & M perf 2P rear //Recaro SPG, SR-2 bucket seats//Sparco 35cm steering wheel//17 inch 8J BBS RX204 front & 9J rear ATS//GruppeM intake system//LTW style rear spoiler//Hella headlights
Jump to top kyrix1st is offline   Reply With Quote
Old Fri, Jun-23-2017, 04:57:09 AM   #10
MaynardZed
Registered User
 
MaynardZed's Avatar
 
Join Date: Mar 2014
Posts: 449
In the garage:
Reputation: 0 MaynardZed is on a distinguished road
Location: Phoenix

United States




Default Re: Oil Pressure Light with Liqui Moly at Track

Normal.

I run 20-50 amsoil race oil and still get that after hard run session. As long as it goes away as soon as throttle blip it's fine.

Just make sure your track car:

1) has oil pump nut secured via weld or wire
2) oil pan baffles e.g. Vac or Turner
3) Do not overheat head. Cooling system must be top notch
4) Do not over rev / float valves
__________________
1999 BMW E36 M3
Ground Control Race Suspension
Full Cage - Flatout Motorworks
OMP Full Containment Race Seat
S52 with bolt ons 237 rwhp (DynoJet)
2600lbs empty
Jump to top MaynardZed is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 02:42:29 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright 1999-2017 M3Forum.com
Discussing Oil Pressure Light with Liqui Moly at Track in the E36 M3 (1992-1999) Forum - {Euro - S50 B32 321hp @ 7400 rpm} {U.S. - S52 B32 240 hp @ 6000 rpm}
Total Produced: 71,212 - Years Produced: 1992 to 1999 at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)