BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > BMW M3 Discussions > E46 M3 (2001-2006)
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All Albums Garage Search Today's Posts Mark Forums Read Calendar FAQ

E46 M3 (2001-2006) Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006.


Reply
 
Thread Tools Display Modes
Old Mon, May-14-2012, 08:39:06 PM   #41
MSpeedAddict
lol stock
 
MSpeedAddict's Avatar
 
Join Date: Dec 2010
Posts: 3,034
In the garage:
Reputation: 0 MSpeedAddict is on a distinguished road
Location: Philadelphia, PA

United States




Default Re: Idle Drop Issue..

Quote:
Originally Posted by Wengy View Post
This is not a problem the car used to have. It started about 2 years after I bought it. If it was a problem with the computer or software, my sense is the problem would be more consistent, no? I mean do ECU's degrade over time? My sense about computers is the work until they don't anymore, and when they fail they stay broken.

Is there any wear and tear on components that might explain the problem? Perhaps the MAF or ICV?
Active has been telling me I need to replace this piece:

09 Hose assy 1 13417837653 $7.25

Apparently become extremely brittle over time, and cracks won't show up in a pressure test because of how short the hose is.
They say easiest way to check is to pull the IM, take off the hose, stretch it. They insist almost every one fails this test and rips apart. Without stretching it you won't see the cracks, and stretching it breaks it instantly.

I'm about to just order it for the hell of it.
FWIW they said it affects the idle oscillating, they weren't talking about the idle drop. (I have both issues).
Jump to top MSpeedAddict is offline   Reply With Quote
Sponsored Links
Register now and remove these ads
Old Wed, May-16-2012, 10:38:10 PM   #42
Wengy
Registered User
 
Join Date: Oct 2009
Posts: 751
In the garage:
Reputation: 0 Wengy is an unknown quantity at this point

Canada




Default Re: Idle Drop Issue..

I took my car in to my local shop, to show them the idle drop issue when the AC was turned off. They took it for a drive, and then they "cleared out all adaptations and performed relearn on all systems." Cost, $43.00 Cdn.

The car drives like new. Idle drop issue appears to be gone, AC on/off, doesn't make a difference. It also seems to pull harder now, but then maybe that's just me and not having had the top down for 6 months.

Knock-on-wood, let's hope that's the end of that annoying issue. Hope this is of some use to the rest of you with this same issue.
Jump to top Wengy is offline   Reply With Quote
Old Thu, May-17-2012, 08:30:06 AM   #43
TJ110
Registered User
 
TJ110's Avatar
 
Join Date: Sep 2011
Posts: 315
In the garage:
Reputation: 0 TJ110 is on a distinguished road
Location: portland

United States




Default Re: Idle Drop Issue..

Quote:
Originally Posted by Wengy View Post
I took my car in to my local shop, to show them the idle drop issue when the AC was turned off. They took it for a drive, and then they "cleared out all adaptations and performed relearn on all systems." Cost, $43.00 Cdn.

The car drives like new. Idle drop issue appears to be gone, AC on/off, doesn't make a difference. It also seems to pull harder now, but then maybe that's just me and not having had the top down for 6 months.

Knock-on-wood, let's hope that's the end of that annoying issue. Hope this is of some use to the rest of you with this same issue.
might need to look into this i have the same problem as u said earlier, when im backing up or pulling in somewhere and i push my clutch in idles drop to 500rpm then back up just recently started happening and i also just recently started using my A/C ? along with that the car lacks power!? i have a 02 6mt with 67K. not sure if maybe my stage 2 afe intake plays a factor?
__________________
19" ZCP's wrapped in Hankook V12's, Stage 2 aFe, SS Race muffler, section 2 x-pipe, SG headers, ST coilovers, OEM short shifter
Jump to top TJ110 is offline   Reply With Quote
Old Thu, May-17-2012, 12:30:45 PM   #44
MSpeedAddict
lol stock
 
MSpeedAddict's Avatar
 
Join Date: Dec 2010
Posts: 3,034
In the garage:
Reputation: 0 MSpeedAddict is on a distinguished road
Location: Philadelphia, PA

United States




Default

Well, I'll clear adaptations again and report back. Anybody local needs it done lemme know.
Jump to top MSpeedAddict is offline   Reply With Quote
Old Thu, May-17-2012, 03:05:42 PM   #45
Jtrem
Registered User
 
Jtrem's Avatar
 
Join Date: Jun 2011
Posts: 1,753
In the garage:
Reputation: 0 Jtrem is on a distinguished road
Location: SoCal

United States




Default Re: Idle Drop Issue..

Quote:
Originally Posted by MSpeedAddict View Post
Well, I'll clear adaptations again and report back. Anybody local needs it done lemme know.
x2 lets hope this works!
Jump to top Jtrem is offline   Reply With Quote
Old Thu, May-17-2012, 04:45:30 PM   #46
amanonfire
Registered User
 
Join Date: Feb 2012
Posts: 745
Reputation: 0 amanonfire is on a distinguished road
Location: The Greatest Place on Earth

Canada




Default Re: Idle Drop Issue..

Quote:
Originally Posted by Wengy View Post
I took my car in to my local shop, to show them the idle drop issue when the AC was turned off. They took it for a drive, and then they "cleared out all adaptations and performed relearn on all systems." Cost, $43.00 Cdn.

The car drives like new. Idle drop issue appears to be gone, AC on/off, doesn't make a difference. It also seems to pull harder now, but then maybe that's just me and not having had the top down for 6 months.

Knock-on-wood, let's hope that's the end of that annoying issue. Hope this is of some use to the rest of you with this same issue.
Where in Canada are you? I'd love to visit the same shop.

Does anyone know if this can be done by pulling the battery for several hours?
Jump to top amanonfire is offline   Reply With Quote
Old Thu, May-17-2012, 04:48:52 PM   #47
Wengy
Registered User
 
Join Date: Oct 2009
Posts: 751
In the garage:
Reputation: 0 Wengy is an unknown quantity at this point

Canada




Default Re: Idle Drop Issue..

Quote:
Originally Posted by amanonfire View Post
Where in Canada are you? I'd love to visit the same shop.

Does anyone know if this can be done by pulling the battery for several hours?
I'm in Nanaimo on Vancouver Island. Although I think any shop with the right BMW software could do a reset.
Jump to top Wengy is offline   Reply With Quote
Old Tue, May-22-2012, 09:41:34 PM   #48
MSpeedAddict
lol stock
 
MSpeedAddict's Avatar
 
Join Date: Dec 2010
Posts: 3,034
In the garage:
Reputation: 0 MSpeedAddict is on a distinguished road
Location: Philadelphia, PA

United States




Default

Finally got to resetting adaptations. I goofed and forgot to read what they were before resetting.

Will report back if anything improves
Jump to top MSpeedAddict is offline   Reply With Quote
Old Tue, May-22-2012, 10:27:47 PM   #49
MSpeedAddict
lol stock
 
MSpeedAddict's Avatar
 
Join Date: Dec 2010
Posts: 3,034
In the garage:
Reputation: 0 MSpeedAddict is on a distinguished road
Location: Philadelphia, PA

United States




Default

Didn't fix anything

...but found something...curious.
Stored code:
80 Switch Chain Frictional Connection

Which the switch for detecting clutch being depressed! I may replace it or at least try to test on GT1

Does anybody with this issue having working cruise control?
I never use it but I know I randomly tried twice during my ownership and it never worked.
Somebody said this sensor will prevent it from working

Last edited by MSpeedAddict; Tue, May-22-2012 at 10:31:58 PM.
Jump to top MSpeedAddict is offline   Reply With Quote
Old Mon, May-28-2012, 05:15:28 PM   #50
Wengy
Registered User
 
Join Date: Oct 2009
Posts: 751
In the garage:
Reputation: 0 Wengy is an unknown quantity at this point

Canada




Default Re: Idle Drop Issue..

Sorry to hear that resetting adaptions didn't work for you. My car is still running without issue after my reset. That code you came up with is interesting however, be curious to know how your diagnostics are coming along, keep us updated.
Jump to top Wengy is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 08:17:38 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright 1999-2014 M3Forum.com
Discussing Idle Drop Issue.. in the E46 M3 (2001-2006) Forum - Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006. at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)