BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > BMW M3 Discussions > E46 M3 (2001-2006)
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All Albums Garage Search Today's Posts Mark Forums Read Calendar FAQ

E46 M3 (2001-2006) Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006.


Reply
 
Thread Tools Display Modes
Old Wed, Sep-22-2010, 02:37:59 PM   #1
zahbaker
Registered User
 
Join Date: Sep 2010
Posts: 8
Reputation: 0 zahbaker is on a distinguished road

South Africa




Default SMG Gearbox Problem-Please help

I drive a 2003 E46 M3 SMG. I recently replaced the clutch kit. I then went on vacation, while on vacation driving the car, the gear indicator started to flash 4th gear. The car then stalled, I then got a BMW mechanic to come out. The car refused to select any gears. The car also would not rev up. I then got a new clutch kit and replaced the one that was fitted in the car, the same problem persists. The car will not select any gears. The error is Fault code (048) 30 Gear cannot be engaged (OBDII: P1756)
I am unable to train or bleed the clucth. I can clear the fault but the moment I turn the ignition back on, the error code returns. Please can somebody assist as I am being charged by the day(Storage and maintenance fees).

Thanx in advance, your help is highly appreciated.
Jump to top zahbaker is offline   Reply With Quote
Sponsored Links
Register now and remove these ads
Old Wed, Sep-22-2010, 02:44:43 PM   #2
kevinzz
Registered User
 
Join Date: Feb 2009
Posts: 112
Reputation: 0 kevinzz is on a distinguished road
Location: Toronto

Canada




Default

My car refused to go in gear one day, I was told that my clutch was done, so my shop replaced the clutch. But that didn't fix the issue. They ended up blaming the SMG actuator, and replaced it. Now my car shifts fine.

If you hear the SMG pump prime, I'd say ask them to check out the actuator..
__________________
2003 SMG Individual NightBlue, beige individual leather, AC handbrake lever, AC pedals, AC front lip, CSL trunk lid, CSL carbon fiber rear diffuser, black kidney grills, black side gills, HID fog, CSL rims, megan racing coilovers, front camber plates, AC tower bar, SS header, SuperSprint race x pipe, Borla muffler, Full carbon fiber intake (same as gruppe M), AA software, Powerflex FCAB, RTABs, RE RSM, Stoptech Stage 2 brake kit, TMS Rear Camber Arms
Jump to top kevinzz is offline   Reply With Quote
Old Wed, Sep-22-2010, 02:51:01 PM   #3
cntrvrsy
44
 
cntrvrsy's Avatar
 
Join Date: Dec 2005
Posts: 6,460
Reputation: 0 cntrvrsy is on a distinguished road
Location: NY

United Nations




Default

I wish I was an SMG guru and had solid answers for you. You can try reading through this thread http://www.m3forum.net/m3forum/showthread.php?t=231113 and the attached .pdf file. It sounds like it could be the Gearbox Actuator but again, I'm not expert and am just guessing.

edit: lol, I was typing as kevinzz posted the same guess
__________________

sig engineered by Fcukupayme
Jump to top cntrvrsy is offline   Reply With Quote
Old Wed, Sep-22-2010, 02:55:40 PM   #4
zahbaker
Registered User
 
Join Date: Sep 2010
Posts: 8
Reputation: 0 zahbaker is on a distinguished road

South Africa




Default

Thanks Guys, I will try replacing the actuator sensor. Will keep you posted. Anybody have a actuator sensor for sale?
Jump to top zahbaker is offline   Reply With Quote
Old Wed, Sep-22-2010, 04:14:54 PM   #5
chalaka
Registered User
 
Join Date: Jun 2007
Posts: 463
In the garage:
Reputation: 0 chalaka is on a distinguished road

Taiwan




Default

after you replace the clutch kit.. did you use the GT1 to reprogram the system?
just wondering ... didn't see you mention that in the post ..

if so, this might be the problem?
Jump to top chalaka is offline   Reply With Quote
Old Wed, Sep-22-2010, 04:24:55 PM   #6
zahbaker
Registered User
 
Join Date: Sep 2010
Posts: 8
Reputation: 0 zahbaker is on a distinguished road

South Africa




Default

Hi, yes the BMW technician did use GT1 to reprogram. The strange thing is that the program will clear the fault, once the ignition is turned on the fault reappears. At this stage, GT1 cannot bleed, or retrain the clutch. No gear will slect. The fault remains with error code (048) 30 Gear cannot be engaged (OBDII: P1756)
Jump to top zahbaker is offline   Reply With Quote
Old Wed, Sep-22-2010, 07:30:46 PM   #7
rve
In ///M we trust.
 
rve's Avatar
 
Join Date: Apr 2010
Posts: 271
In the garage:
Reputation: 0 rve is on a distinguished road
Location: Pleven, Bulgaria

Bulgaria




Default

It could be something much simpler like the salmon colored relay (PN: 12631742690) for example. I would check that first because it's known to fail, it could lead exactly to the problem you have (gear can not be engaged) and it costs just a few bucks. Also, since you get the fault code each time you turn the ignition on sounds like it's a rather software/electrical problem than mechanical.
__________________
The throttle remains in "Sport" mode, the DSC is Off and the smile just gets wider... and wider...



Jump to top rve is offline   Reply With Quote
Old Thu, Sep-23-2010, 07:13:25 AM   #8
zahbaker
Registered User
 
Join Date: Sep 2010
Posts: 8
Reputation: 0 zahbaker is on a distinguished road

South Africa




Default

Thanks for that, it was the first thing I swopped out, the problem still persists.
Jump to top zahbaker is offline   Reply With Quote
Old Thu, Sep-23-2010, 08:12:04 AM   #9
DirtyM
Registered User
 
Join Date: Jul 2010
Posts: 218
Reputation: 0 DirtyM is on a distinguished road

United States




Default

Look into the compression spring as well. Mine was only related to 3rd 5th and 6th shifting above 3k or so but, I did get the same code p1756.Being as how yours is affecting all the gears I'd say maybe the gear sensor on the back of the trans as well.
Jump to top DirtyM is offline   Reply With Quote
Old Thu, Sep-23-2010, 08:22:38 AM   #10
zahbaker
Registered User
 
Join Date: Sep 2010
Posts: 8
Reputation: 0 zahbaker is on a distinguished road

South Africa




Default

Thanks, I will ask the engineer to have a look.
Jump to top zahbaker is offline   Reply With Quote
Reply

Bookmarks

Tags
gearbox, problemplease, smg

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 12:45:31 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright 1999-2017 M3Forum.com
Discussing SMG Gearbox Problem-Please help in the E46 M3 (2001-2006) Forum - Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006. at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)