BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > BMW M3 Discussions > E46 M3 (2001-2006)
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All Albums Garage Search Today's Posts Mark Forums Read Calendar FAQ

E46 M3 (2001-2006) Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006.


Reply
 
Thread Tools Display Modes
Old Wed, Dec-14-2016, 03:57:43 AM   #921
DJ RaMiN
Registered User
 
Join Date: Apr 2014
Posts: 5
Reputation: 0 DJ RaMiN is on a distinguished road

United States




Default Re: SMG troubleshooting FAQ

Hey guys. I couldn't find any info on my issue. I've been getting the cog light every now and then and usually it goes away after a restart. Car shifts fine and no problems there. I don't think its a high temperature issue since it happens now in winter. Any thoughts would be appreciated.

Thanks.
Jump to top DJ RaMiN is offline   Reply With Quote
Sponsored Links
Register now and remove these ads
Old Thu, Jan-12-2017, 05:02:30 AM   #922
j-dog
Jdog
 
j-dog's Avatar
 
Join Date: Aug 2006
Posts: 203
Reputation: 0 j-dog is on a distinguished road
Location: NC San Diego

United States




Default Re: SMG troubleshooting FAQ

Heads up to those who have the cog light with no SMG symptoms:

Prior to my SMG-6MT swap, I had the SMG cog light go on with no driving symptoms at all. I was already planning on getting the swap done anyways. KAIV tested my SMG prior to doing the swap, and he found no other issue other than 'power supply" error.

Approx. 2 months earlier, I had issues with my radio randomly and intermittently shutting off for a few seconds and then coming back on. This radio issue gradually became more frequent and the shut offs became minutes. The car otherwise worked fine, i thought my radio was on the blink. Then my cog light went on.

KAIV discovered that my alternator was overcharging, at times up to 16 volts! Since I changed the alternator, my radio issues are gone. I am 99.9% certain that the over charging alternator also caused the "power supply" error since all other systems of my SMG checked out as A-OK.
__________________

06 ZCP. Jet Black.
Jump to top j-dog is offline   Reply With Quote
Old Wed, Jan-18-2017, 08:25:25 PM   #923
cncmastr
M-Texture Alcantara
 
cncmastr's Avatar
 
Join Date: Aug 2003
Age: 35
Posts: 1,182
In the garage:
Reputation: 0 cncmastr is on a distinguished road
Location: Toms River, NJ

United States




Default Re: SMG troubleshooting FAQ

Just wanted to say thank you for posting this. I had the blinking light, my hood was open. duh!
__________________
2006 Interlagos Blue BMW ///M3 | ZCP | Xenon | Nav | Premium | M Texture Alcantara | Euro Headers & Cats | Evolve R Tune | CSL Airbox

Collection of my DIY Guides here
Jump to top cncmastr is offline   Reply With Quote
Old Wed, Jan-18-2017, 09:07:51 PM   #924
daytonaviolet
OEM CSL Whoore
 
daytonaviolet's Avatar
 
Join Date: Jan 2004
Posts: 22,709
Reputation: 0 daytonaviolet is on a distinguished road
Location: Bay Area, CA

Philippines




Default Re: SMG troubleshooting FAQ

Quote:
Originally Posted by cncmastr View Post
Just wanted to say thank you for posting this. I had the blinking light, my hood was open. duh!
i've done several times
__________________
Click my sig and view my pics!


Tischer aka GetBmwParts
Jump to top daytonaviolet is offline   Reply With Quote
Old Thu, Jan-19-2017, 05:54:36 AM   #925
0-60Motorsports
Established 1998....
 
0-60Motorsports's Avatar
 
Join Date: Mar 2004
Posts: 13,715
In the garage:
Reputation: 0 0-60Motorsports is on a distinguished road
Location: Al Manama, Bahrain

Bahrain




Default Re: SMG troubleshooting FAQ

Hey guys, While driving in S3 or Any manual mode, when im slowing down either it be slowly or aggressively there is a forward jerk while shifting down. Any ideas? I haven't scanned for any codes yet but will do soon. Also no SMG light etc on the dash.
__________________
EURO 04 M3 Current Mods: GC DA's / Eibach Sways / PF RTABs / RE RCAs / INTRAVEE II / Black Roundels / ///MFEST Badges / Depo Corners / M5 SMG Knob / VCSL: Bumper + Race Lip, CF Trunk, CF Diffusor / DIETZ TV in Motion / SuperSprint: Stepped Headers, Cat Deletes, Res X-pipe, Sport Muffler / Z8 Starter Button / Lamin-X / STM Paddles / OEM CSL: Steering, Interior, Intake, CF Roof / Terra MSS54HP CSL Clone / BBS CH's, LIGHTWERKZ / ST40's / DINAN RSB / BW Oil Cooler / 3.91 gears / Radium OCC
Jump to top 0-60Motorsports is offline   Reply With Quote
Old Thu, Jan-19-2017, 07:46:18 AM   #926
Flow
Registered User
 
Flow's Avatar
 
Join Date: Mar 2011
Posts: 2,761
In the garage:
Reputation: 0 Flow is on a distinguished road
Location: France

France




Default Re: SMG troubleshooting FAQ

Quote:
Originally Posted by 0-60Motorsports View Post
Hey guys, While driving in S3 or Any manual mode, when im slowing down either it be slowly or aggressively there is a forward jerk while shifting down. Any ideas? I haven't scanned for any codes yet but will do soon. Also no SMG light etc on the dash.
My bet is on clutch adaptation. Engine rev matches before completely disengaging the clutch, which makes the car jerk forward.
Redo the clutch adaptation and see if it helps
__________________
- Florian E46 M3 tightening torques PDF
2004 M3 TiAg / LSB SMG
Jump to top Flow is offline   Reply With Quote
Old Sat, Feb-04-2017, 03:55:05 PM   #927
Thenakedflyer
Registered User
 
Join Date: Sep 2016
Posts: 11
Reputation: 0 Thenakedflyer is on a distinguished road

United Kingdom




Default Re: SMG troubleshooting FAQ

Reading with interest.. Ran the bleed program for actuator and clutch in inpa no errors all fine then went to do the adaptions after that. The procedure failed at clutch opening about four minutes in. All gears 'measured' then a message flashes up shift path something for a split second then clutch opening then procedure break.. Error report says " time for adjusting the selector angle (WW) too long "... Anybody shed any light on what this means?
Car has 110k miles on the clock but a pump from a 68k car in it which primes and works great. Car drives really good quick changes and no issues apparent other than the cog light on.
I have the adaption values if they are useful...
Any info advice much appreciated..
Jump to top Thenakedflyer is offline   Reply With Quote
Old Mon, Feb-06-2017, 09:33:00 PM   #928
Vilius
Registered User
 
Join Date: Feb 2017
Posts: 1
Reputation: 0 Vilius is on a distinguished road
Location: Norwich

United Kingdom




Default Re: SMG troubleshooting FAQ

Hello, guys, I recently have bought 325i (it is not m3, but maybe You won't get very mad) 2003y with SSG (or SMGI) gearbox. Sadly, it has problem: sometimes gearbox works as normal and sometimes it feels like clutch is slipping- try to drive, but the engine revs is jumping between 2000 and 4000 and the car is barely moving (if you "torture" the car, you can smell the clutch at this situation), as well in this situation slipping is feeling in all gears. At this point you turn off/turn (remove the key) on engine and for a while gearbox is working quite fine. These symptoms mostly appears while driving in a city with more stop/go intervals, at long journey gearbox works quite fine. Which part of gearbox problem it could be? Last owner had told that clutch is changed not many times ago (there are all bills- clutch, labor, reset). Could it be SMG relay- but as I found in other topics, relay symptoms are different, in mine car the pump is working, engine starts every time, no COG lights (just several times there were DSC/ABS/Brake lights up, but after a while they gone), INPA don't show any error. If any of You have similar experience, please let me know how do You solve it. Cheers

Last edited by Vilius; Mon, Feb-06-2017 at 09:42:22 PM.
Jump to top Vilius is offline   Reply With Quote
Reply

Bookmarks

Tags
faq, smg, troubleshooting

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubleshooting Codes AirDoc E36 M3 (1992-1999) 0 Sat, Nov-17-2007 04:49:53 AM
Troubleshooting a problem ----> HELP ! RoadShreader E36 M3 (1992-1999) 43 Sun, Dec-31-2006 08:05:57 PM
Eclipse Troubleshooting crazy32184 E36 M3 (1992-1999) 7 Thu, Jun-09-2005 08:03:15 AM
HELP PLEASE!!! Troubleshooting my ///M! M3nEwBoOtY E36 M3 (1992-1999) 6 Sun, Apr-03-2005 05:37:52 PM



All times are GMT. The time now is 03:41:11 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright 1999-2014 M3Forum.com
Discussing SMG troubleshooting FAQ in the E46 M3 (2001-2006) Forum - Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006. at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)