BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > BMW M3 Discussions > E46 M3 (2001-2006)
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All Albums Garage Search Today's Posts Mark Forums Read Calendar FAQ

E46 M3 (2001-2006) Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006.


Reply
 
Thread Tools Display Modes
Old Sat, Oct-13-2018, 12:54:35 AM   #1
BMW>Everything
Registered User
 
Join Date: Sep 2016
Posts: 54
Reputation: 0 BMW>Everything is on a distinguished road

United States




Default Harness HELP!

So my front bumper harness got ripped and made a huge mess. It yanked out the fog light, ambient air temp, horn, and a little past the big round connecter. I went and bought a whole new harness from ebay which is taken from a E46 M3. The seller told me they are all the same however I noticed 2 things. I have 1 extra wire (White/Red) that leads off to a little connect that I can't plug anything into, and I noticed that my twisted wire pair from my harness is (Purple/Red) & (Blue/Brown) however the harness I purchased has it's twisted pairs (Blue/Brown) & (Blue/Red). I still connected them even though the colors don't match. Everything works including my headlights and all the features. (High Beam, Low Beam, Fog, Ambient Temp.) But now my cluster is sometimes dead and my headunit won't turn on.... Any ideas why this could be happening?




Last edited by BMW>Everything; Sat, Oct-13-2018 at 01:00:23 AM.
Jump to top BMW>Everything is offline   Reply With Quote
Sponsored Links
Register now and remove these ads
Old Sat, Oct-13-2018, 02:51:15 AM   #2
BMW>Everything
Registered User
 
Join Date: Sep 2016
Posts: 54
Reputation: 0 BMW>Everything is on a distinguished road

United States




Default Re: Harness HELP!

Also when I turn on the ignition, the only thing the cluster lights up is the ABS light for 2 sec then I hear a click and it turns off... everything else stay dead.
Jump to top BMW>Everything is offline   Reply With Quote
Old Sun, Oct-14-2018, 12:38:26 AM   #3
qualicas
Registered User
 
qualicas's Avatar
 
Join Date: May 2010
Posts: 1,194
In the garage:
Reputation: 0 qualicas is on a distinguished road
Location: Calgary

Canada




Default Re: Harness HELP!

There would be a couple different harnesses. One from a 2001 with HID regular Xenons. Then 2002 on it is Bi-xenon. Last there is regular Halogen lights. There could be more depending on options like headlight washers. Sounds to me like you maybe blew a fuse for the cluster somehow.

Be aware that Brown is always ground. find a wiring diagram and follow it. I replaced wiring on 2 M3 front ends and didn't have any cluster issues.
Jump to top qualicas is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 04:35:38 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright 1999-2017 M3Forum.com
Discussing Harness HELP! in the E46 M3 (2001-2006) Forum - Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006. at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)