BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > BMW M3 Discussions > E90 M3 (Sedan) | E92 M3 (Coupe) | E93 M3 (Convertible) (2008-2013)
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All Albums Garage Search Today's Posts Mark Forums Read Calendar FAQ

E90 M3 (Sedan) | E92 M3 (Coupe) | E93 M3 (Convertible) (2008-2013) {Engine: S65 - Max Hp: 414 hp (420 hp Euro) at 8,300 rpm / 295 lb/ft at 3,900 rpm}


Reply
 
Thread Tools Display Modes
Old Wed, Aug-05-2015, 02:59:23 PM   #1
Mkpoto
Registered User
 
Join Date: Jun 2010
Posts: 453
Reputation: 0 Mkpoto is on a distinguished road

United States




Default Issues with E92 M3 - PLEASE HELP!

I know this is more of a E46 M3 forum, but seeing that there are no one over at the dedicated forums, and more knowledgable people here I thought I would post this here:

I am currently running the Evolve E600 kit on my car and have been having some issues lately.

Here is the back story, I have been having some issues with the car. I originally started out with the following codes:

279D - Power Management battery closed circuit violation
260D - Idle Speed control valve monitor bank 1
2B57 - Motor emergency program activated
275E - Lambda control stop error 1

I knew right away that my ICV was failing, and with the erratic idling problem, knew that it was what needed to be fixed. I also had a mechanic look over my car and let me know my fuel pressure sensor was going out was well. So had that replaced. Once the ICV was replaced the car would idle fine, but the the following codes were left.

275D - Lambda control stop error bank 1
275E - Lambda control stop error bank 2
2B57 - Motor emergency program activated

I then went ahead and replaced my 02s and was left with the the 275De code, which is the main code that I am seeing now. So in anger I told my shop friend to take the car and diagnosis the car. One the drive the car went into limp mode and when I would turn off and turn on the car would run find and do it again 10-15 minutes later. So my friend started to peak around the car and came back and let me know I had a low voltage issue. He also let me know that some of the sensors could be freaking out and causing the problem. So i took the car to him, on the drive over the car went into limp mode.

He checked the car out and replaced the battery. I took it for a spin for 20-30 minutes and no codes nothing. So the car sat at his shop getting BBKs installed and I come to pick it up and boom the code pops up again.

The car runs fine, I even put the stock tune back on to see if the code would pop up and sure enough does the same thing. I do not think it is the tune that is the issue.

Can anyone help me out? I am stumped...
__________________
BMW E92 M3
EVOLVE E600 Supercharger | EVOLVE X-Pipe | EVOLVE E-Tronic Exhaust
| KW V3 | HRE R40 | BMW Performance Spoiler
Jump to top Mkpoto is offline   Reply With Quote
Sponsored Links
Register now and remove these ads
Old Wed, Aug-05-2015, 03:54:21 PM   #2
foolio
40oz. to Freedom
 
Join Date: Sep 2008
Posts: 1,009
In the garage:
Reputation: 0 foolio is on a distinguished road
Location: Indianapolis

United States




Default Re: Issues with E92 M3 - PLEASE HELP!

So, new battery fixed the problem for a short while...have you checked the alternator? What year is the car and how many miles?
__________________

______________________________________________
1981 BMW 320is - 5MT - Polaris/Black
2001 BMW 325xiT - 5MT - TiAg/Grey Leather - ZPP, ZSP, ZCW, NAV, PDC
2002 BMW M3 - SMG - TiAg/Black Leather - KWV3
2003 BMW M3 - SMG - Laguna Seca Blue - Track car, track stuff
______________________________________________
Jump to top foolio is offline   Reply With Quote
Old Wed, Aug-05-2015, 04:32:58 PM   #3
Mkpoto
Registered User
 
Join Date: Jun 2010
Posts: 453
Reputation: 0 Mkpoto is on a distinguished road

United States




Default Re: Issues with E92 M3 - PLEASE HELP!

Quote:
Originally Posted by foolio View Post
So, new battery fixed the problem for a short while...have you checked the alternator? What year is the car and how many miles?
yes checked alternator and it is working fine. The car currently has 42xxx miles.
__________________
BMW E92 M3
EVOLVE E600 Supercharger | EVOLVE X-Pipe | EVOLVE E-Tronic Exhaust
| KW V3 | HRE R40 | BMW Performance Spoiler
Jump to top Mkpoto is offline   Reply With Quote
Old Wed, Aug-05-2015, 06:48:25 PM   #4
Mkpoto
Registered User
 
Join Date: Jun 2010
Posts: 453
Reputation: 0 Mkpoto is on a distinguished road

United States




Default Re: Issues with E92 M3 - PLEASE HELP!

Here is another questions. Can a exhaust leak before 02s cause this? My only issue with this if so why does it come up so quickly? (pretty much shows up when I start the car)
__________________
BMW E92 M3
EVOLVE E600 Supercharger | EVOLVE X-Pipe | EVOLVE E-Tronic Exhaust
| KW V3 | HRE R40 | BMW Performance Spoiler
Jump to top Mkpoto is offline   Reply With Quote
Old Thu, Aug-06-2015, 09:14:28 PM   #5
second_2_nun
Registered User
 
second_2_nun's Avatar
 
Join Date: Jul 2008
Posts: 92
Reputation: 0 second_2_nun is on a distinguished road

United States




Default Re: Issues with E92 M3 - PLEASE HELP!

My e92 m3 had a exhaust leak that caused cyclinder banks 5678 to misfire. My car was down for almost 6 months and after doing rod bearings and everything else but a new motor, the problem was eventually solved after another breakdown couldn't find any damage to the crank a missing exhaust gasket!!!! $3,000 later and 5 months of not driving her putting it back to stock. I've since moved on to a hybrid, man I miss my e92! goodluck
Jump to top second_2_nun is offline   Reply With Quote
Old Thu, Aug-06-2015, 10:09:34 PM   #6
hogger453
Registered User
 
hogger453's Avatar
 
Join Date: Aug 2006
Posts: 8,129
In the garage:
Reputation: 0 hogger453 is on a distinguished road
Location: Los Angeles

Bulgaria




Default Re: Issues with E92 M3 - PLEASE HELP!

Just take it to the dealer.
__________________


Two possibilities exist:

Either we are alone in the universe or we are not.
Both are equally terrifying.


Arthur C. Clarke
Jump to top hogger453 is offline   Reply With Quote
Old Mon, Aug-10-2015, 03:27:02 AM   #7
Mkpoto
Registered User
 
Join Date: Jun 2010
Posts: 453
Reputation: 0 Mkpoto is on a distinguished road

United States




Default Re: Issues with E92 M3 - PLEASE HELP!

Quote:
Originally Posted by hogger453 View Post
Just take it to the dealer.
not taking my car to the dealer with the blower on it. I do have an exhaust leak and had that resolved, still have the issue with a emission increase. I have a track day tomorrow and this is beyond annoying!
__________________
BMW E92 M3
EVOLVE E600 Supercharger | EVOLVE X-Pipe | EVOLVE E-Tronic Exhaust
| KW V3 | HRE R40 | BMW Performance Spoiler
Jump to top Mkpoto is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 11:24:44 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright 1999-2017 M3Forum.com
Discussing Issues with E92 M3 - PLEASE HELP! in the E90 M3 (Sedan) | E92 M3 (Coupe) | E93 M3 (Convertible) (2008-2013) Forum - {Engine: S65 - Max Hp: 414 hp (420 hp Euro) at 8,300 rpm / 295 lb/ft at 3,900 rpm} at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)