BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > BMW M3 Discussions > E46 M3 (2001-2006)
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All Albums Garage Search Today's Posts Mark Forums Read Calendar FAQ

E46 M3 (2001-2006) Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006.


Reply
 
Thread Tools Display Modes
Old Sun, May-16-2010, 07:35:16 PM   #21
rkmM3
Registered User
 
Join Date: Dec 2009
Posts: 158
Reputation: 0 rkmM3 is on a distinguished road

United States




Default

Quote:
Originally Posted by Philly_swedem View Post
Did you have the same symptoms as mine?

- P0121
- EML
- DSC

= Limp mode

Haven't got my TPS yet.
The First time mine came on i was on the highway and then it was just "EML" when i came to a slow the dsc came on. I restarted the car it drove fine for a few days. NO SES yet. i went home read it for pending codes and i had a p0221 then i was like eml scares me. so i went on the forums and read everything it was TPS. So i just waited for it to come back, first time it took 3 days to come back, i probably drove the car 2 weeks with out replacing it, then i was driving and eml + ses and the code was P0121. which i think is for the TPS next to the oil filter. I have replaced it and it drives fine up until now 20+ miles no prob.

So yes, when i replaced it, i had the same symptoms...i stopped driving it when the SES came on, and parked it.

I really do hope that is your prob. if it were to come back i'd go Gas pedal next. then under the manifold.

Last edited by rkmM3; Sun, May-16-2010 at 07:40:35 PM.
Jump to top rkmM3 is offline   Reply With Quote
Sponsored Links
Register now and remove these ads
Old Sun, May-16-2010, 07:38:59 PM   #22
rkmM3
Registered User
 
Join Date: Dec 2009
Posts: 158
Reputation: 0 rkmM3 is on a distinguished road

United States




Default

Quote:
Originally Posted by KILO15 View Post
Ha..I needed to do this and had no idea where it was. Good thing I already have the manifold off.
haha man..good luck...i think the guy who posted the pic was really helpful...
Jump to top rkmM3 is offline   Reply With Quote
Old Sun, May-16-2010, 09:44:35 PM   #23
Philly_swedem
Registered User
 
Philly_swedem's Avatar
 
Join Date: Nov 2008
Posts: 462
In the garage:
Reputation: 0 Philly_swedem is on a distinguished road

Sweden




Default

Quote:
Originally Posted by rkmM3 View Post
The First time mine came on i was on the highway and then it was just "EML" when i came to a slow the dsc came on. I restarted the car it drove fine for a few days. NO SES yet. i went home read it for pending codes and i had a p0221 then i was like eml scares me. so i went on the forums and read everything it was TPS. So i just waited for it to come back, first time it took 3 days to come back, i probably drove the car 2 weeks with out replacing it, then i was driving and eml + ses and the code was P0121. which i think is for the TPS next to the oil filter. I have replaced it and it drives fine up until now 20+ miles no prob.

So yes, when i replaced it, i had the same symptoms...i stopped driving it when the SES came on, and parked it.

I really do hope that is your prob. if it were to come back i'd go Gas pedal next. then under the manifold.
Did you clear the code or did the light go out by itself?
Jump to top Philly_swedem is offline   Reply With Quote
Old Sun, May-16-2010, 11:06:25 PM   #24
rkmM3
Registered User
 
Join Date: Dec 2009
Posts: 158
Reputation: 0 rkmM3 is on a distinguished road

United States




Default

Quote:
Originally Posted by Philly_swedem View Post
Did you clear the code or did the light go out by itself?
Cleared it, i bought a $30 USB to OBDii cable for generic code reading and such.
Jump to top rkmM3 is offline   Reply With Quote
Old Mon, May-17-2010, 07:37:13 PM   #25
Philly_swedem
Registered User
 
Philly_swedem's Avatar
 
Join Date: Nov 2008
Posts: 462
In the garage:
Reputation: 0 Philly_swedem is on a distinguished road

Sweden




Default

Ok guys.

Started the car today, EML + motorlamp.

Changed the TPS:

EML got out instantly, still had the motorlamp on.

Erased the code.

The car feels SOOO smooth now with the new TPS, i would recommend everyone to change it, never felt so smooth shifts before, even when cold!

I have been out driving for an hour without any lights *knock on wood*

Very very happy now, thanks guys
Jump to top Philly_swedem is offline   Reply With Quote
Old Mon, May-17-2010, 09:01:37 PM   #26
rkmM3
Registered User
 
Join Date: Dec 2009
Posts: 158
Reputation: 0 rkmM3 is on a distinguished road

United States




Default

Quote:
Originally Posted by Philly_swedem View Post
Ok guys.

Started the car today, EML + motorlamp.

Changed the TPS:

EML got out instantly, still had the motorlamp on.

Erased the code.

The car feels SOOO smooth now with the new TPS, i would recommend everyone to change it, never felt so smooth shifts before, even when cold!

I have been out driving for an hour without any lights *knock on wood*

Very very happy now, thanks guys
Im very happy it solved your problem, im in the same boat! whats the "motorlamp"? do you mean "service engine soon"
Jump to top rkmM3 is offline   Reply With Quote
Old Mon, May-17-2010, 09:05:17 PM   #27
Philly_swedem
Registered User
 
Philly_swedem's Avatar
 
Join Date: Nov 2008
Posts: 462
In the garage:
Reputation: 0 Philly_swedem is on a distinguished road

Sweden




Default

Quote:
Originally Posted by rkmM3 View Post
Im very happy it solved your problem, im in the same boat! whats the "motorlamp"? do you mean "service engine soon"
Sorry, meant engine light, don't know what you call it

thanks man!

Jump to top Philly_swedem is offline   Reply With Quote
Old Mon, May-17-2010, 09:09:09 PM   #28
rkmM3
Registered User
 
Join Date: Dec 2009
Posts: 158
Reputation: 0 rkmM3 is on a distinguished road

United States




Default

Quote:
Originally Posted by Philly_swedem View Post
Sorry, meant engine light, don't know what you call it

thanks man!

I have an 2002 and it literally says Service Engine Soon for me. Maybe it was changed on your year. Anyways....Problem solved hopefully this thread comes in handy for many people. :-)

Last edited by rkmM3; Mon, May-17-2010 at 09:09:49 PM. Reason: adding stuff
Jump to top rkmM3 is offline   Reply With Quote
Old Mon, May-17-2010, 09:11:17 PM   #29
Philly_swedem
Registered User
 
Philly_swedem's Avatar
 
Join Date: Nov 2008
Posts: 462
In the garage:
Reputation: 0 Philly_swedem is on a distinguished road

Sweden




Default

Quote:
Originally Posted by rkmM3 View Post
I have an 2002 and it literally says Service Engine Soon for me. Maybe it was changed on your year. Anyways....Problem solved hopefully this thread comes in handy for many people. :-)
No, I have an EURO M3, so no SES light here

edit: But don't you have that light as well? It's a standard light in every car :S

Here are the lights I had when I got P0121:



And DSC as well

Last edited by Philly_swedem; Mon, May-17-2010 at 09:15:20 PM.
Jump to top Philly_swedem is offline   Reply With Quote
Old Mon, May-17-2010, 09:31:36 PM   #30
rkmM3
Registered User
 
Join Date: Dec 2009
Posts: 158
Reputation: 0 rkmM3 is on a distinguished road

United States




Default

Quote:
Originally Posted by Philly_swedem View Post
No, I have an EURO M3, so no SES light here

edit: But don't you have that light as well? It's a standard light in every car :S

Here are the lights I had when I got P0121:



And DSC as well
Not only do you have few extra horses, you have sh*t ton of lights. Yeah those 2 are the ones that went off for me.

I guess BMW doesnt think Americans are capable of understanding that a motor lighting up on the dash means that something is wrong lol.

They were the exact ones that were on, and they are off now
Jump to top rkmM3 is offline   Reply With Quote
Reply

Bookmarks

Tags
diys, intake, manifold, tps

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 09:43:43 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright 1999-2017 M3Forum.com
Discussing TPS under intake Manifold, any DIYs in the E46 M3 (2001-2006) Forum - Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006. at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)