BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > BMW M3 Discussions > E46 M3 (2001-2006)
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All Albums Garage Search Today's Posts Mark Forums Read Calendar FAQ

E46 M3 (2001-2006) Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006.


Reply
 
Thread Tools Display Modes
Old Tue, Mar-14-2017, 01:23:07 PM   #1
BubbaTree
BubbaTree
 
Join Date: Nov 2013
Posts: 176
Reputation: 0 BubbaTree is on a distinguished road
Location: Surprise

United States




Default Schmiedmann Trunk Wiring Kit

My '03 vert with SMG has that on and off glitch in the trunk wiring that prevents starting the engine from time to time. Actually, it won't shift into "0" to allow engine starting. When it happens, I have to open and close the trunk, and all's well. Seems to be a wiring issue in the trunk lid, and I've replaced the micro switch, as well as soldered that broken brown wire. Still happens sometime, and I'm looking for a more permanent fix. Searching the forums seems to show no real fix, aside from annually checking/re-soldering the wiresAnyone used this wiring kit, or found a better fix? I haven't yet checked the wiring since the gremlin returned; any other suspects that might be causing this starting issue? Maybe bad grounding through a light bulb? Appreciate any help.
Thanks.

Last edited by BubbaTree; Tue, Mar-14-2017 at 01:28:24 PM. Reason: clarity
Jump to top BubbaTree is offline   Reply With Quote
Sponsored Links
Register now and remove these ads
Old Tue, Mar-14-2017, 05:02:16 PM   #2
Uncle Marc
Registered User
 
Uncle Marc's Avatar
 
Join Date: Jan 2015
Posts: 78
In the garage:
Reputation: 0 Uncle Marc is on a distinguished road
Location: Bethlehem, Pa

United States




Default Re: Schmiedmann Trunk Wiring Kit

When this happens to you, is the instrument cluster light for the "trunk ajar" on?
Jump to top Uncle Marc is offline   Reply With Quote
Old Wed, Mar-15-2017, 01:33:33 PM   #3
BubbaTree
BubbaTree
 
Join Date: Nov 2013
Posts: 176
Reputation: 0 BubbaTree is on a distinguished road
Location: Surprise

United States




Default Re: Schmiedmann Trunk Wiring Kit

When I get this no-start condition, there is no indication at all that there's a problem, aside from the fact that the trans will not shift into "0", neutral. It will shift into 1st, 2nd, and R. No instrument cluster lights, I hear the SMG pump priming, and all other normal conditions seem to occur. Invariably, I can start the engine by opening and closing the trunk lid. Previously, I've seen the brown ground wire broken, repaired that, and the engine starts. Currently, there are no broken wires, but the engine failed to start recently until I open/shut the trunk. I'm wondering if there's also a bad ground point for that brown wire inside the trunk; where is that grounding point? One of the light bulbs, maybe? All bulbs work, and I never get an instrument cluster warning that a light is bad.
Jump to top BubbaTree is offline   Reply With Quote
Old Wed, Mar-15-2017, 09:23:13 PM   #4
Jaap
Registered User
 
Join Date: May 2015
Posts: 147
Reputation: 0 Jaap is on a distinguished road

United States




Default Re: Schmiedmann Trunk Wiring Kit

Maybe the sensor that is not in the trunk lid but in the sill?
Jump to top Jaap is offline   Reply With Quote
Old Wed, Mar-15-2017, 10:24:48 PM   #5
Uncle Marc
Registered User
 
Uncle Marc's Avatar
 
Join Date: Jan 2015
Posts: 78
In the garage:
Reputation: 0 Uncle Marc is on a distinguished road
Location: Bethlehem, Pa

United States




Default Re: Schmiedmann Trunk Wiring Kit

Quote:
Originally Posted by Jaap View Post
Maybe the sensor that is not in the trunk lid but in the sill?
That is what I was thinking when I asked about the "trunk ajar" light being on
Jump to top Uncle Marc is offline   Reply With Quote
Old Wed, Mar-15-2017, 10:36:27 PM   #6
daytonaviolet
OEM CSL Whoore
 
daytonaviolet's Avatar
 
Join Date: Jan 2004
Posts: 23,469
Reputation: 0 daytonaviolet is on a distinguished road
Location: Bay Area, CA

Philippines




Default Re: Schmiedmann Trunk Wiring Kit

but i think if the trunk indicator is "on", you can still start and drive the car.

ps.. or perhaps its different with a vert?
__________________
Click my sig and view my pics!


Tischer aka GetBmwParts
Jump to top daytonaviolet is offline   Reply With Quote
Old Thu, Mar-16-2017, 02:32:38 AM   #7
BubbaTree
BubbaTree
 
Join Date: Nov 2013
Posts: 176
Reputation: 0 BubbaTree is on a distinguished road
Location: Surprise

United States




Default Re: Schmiedmann Trunk Wiring Kit

Just checked this out, and the car will start with the trunk, doors, and even the hood open. The instrument cluster shows all lights for everything, except, it doesn't show the hood to be open. The car should not start with the hood open, so, maybe that sensor is what I need to check?

Last edited by BubbaTree; Thu, Mar-16-2017 at 02:33:03 AM. Reason: typos
Jump to top BubbaTree is offline   Reply With Quote
Old Thu, Mar-16-2017, 04:08:51 AM   #8
daytonaviolet
OEM CSL Whoore
 
daytonaviolet's Avatar
 
Join Date: Jan 2004
Posts: 23,469
Reputation: 0 daytonaviolet is on a distinguished road
Location: Bay Area, CA

Philippines




Default Re: Schmiedmann Trunk Wiring Kit

If the front hood is open, car will start but not drive (smg)
__________________
Click my sig and view my pics!


Tischer aka GetBmwParts
Jump to top daytonaviolet is offline   Reply With Quote
Old Thu, Mar-16-2017, 12:19:35 PM   #9
Uncle Marc
Registered User
 
Uncle Marc's Avatar
 
Join Date: Jan 2015
Posts: 78
In the garage:
Reputation: 0 Uncle Marc is on a distinguished road
Location: Bethlehem, Pa

United States




Default Re: Schmiedmann Trunk Wiring Kit

Does the top go down?
If the car thinks the trunk is open, it will not allow the top to operate because it anticipates a collision between the tonneau cover and the top itself.

I'm sure this is frustrating, I hope you get it figured out
Jump to top Uncle Marc is offline   Reply With Quote
Old Fri, Mar-17-2017, 02:17:17 AM   #10
BubbaTree
BubbaTree
 
Join Date: Nov 2013
Posts: 176
Reputation: 0 BubbaTree is on a distinguished road
Location: Surprise

United States




Default Re: Schmiedmann Trunk Wiring Kit

Thanks for the insight, guys, and I again checked out everything I can visually check. The instrument cluster "hood Ajar" light is dark when the hood is open. All other similar lights work correctly. The SMG will not shift into "0"/neutral, nor will the engine start with the hood open. Close the hood, and the trans goes to 0, and the engine starts. Still kind of funky that the open/close the trunk lid seems to reset the gremlin, and the trans goes to 0, and the engine starts. If this issue develops any further, I'll post whatever I learn.Thanks.

Last edited by BubbaTree; Fri, Mar-17-2017 at 01:00:18 PM. Reason: clarity
Jump to top BubbaTree is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 03:18:19 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright 1999-2017 M3Forum.com
Discussing Misfires/rough driving after VANOS work! in the E46 M3 (2001-2006) Forum - Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006. at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)