BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > BMW M3 Discussions > E46 M3 (2001-2006)
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All Albums Garage Search Today's Posts Mark Forums Read Calendar FAQ

E46 M3 (2001-2006) Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006.


Reply
 
Thread Tools Display Modes
Old Tue, Oct-23-2018, 07:32:07 PM   #21
Race M3
I can put whatever I want here?
 
Join Date: Jun 2014
Posts: 55
Reputation: 0 Race M3 is on a distinguished road
Location: Classified

United States




Default Re: Need help, hard start when vehicle warm runs flawlessly after. DME faults

Quote:
Originally Posted by CSLM3Wannabi View Post
Condition and age of battery? Every fault listed is provided power via the DME relay. Insufficient power to the relay will cause a delay. Relay may also be failing.
I suggest...
checking/testing battery
Testing fuel pressure at the rail AFTER car has sat overnight with gauge connected.

When was fuel filter replaced last? Age? Mileage?


Sent from my iPhone using Tapatalk
Battery was replaced a couple months ago about 3 weeks after the vanos job (when all of this started to happen) new interstate battery charge is good, alternator is charging good. voltage good when cranking.

fuel filter was just replaced this past week

fuel pressure... its normal to leak down some after a few hours. this problem still happens even when i measured full 5 bar after sitting 30 minutes. fuel pressure regulator seems to be working as well when i remove vacuum or blip throttle pressure increases at idle.


in the dme i kept getting fuel injector driver 1 overtemp that would return after a while of driving. no lights hasnt returned yet since i had the injectors cleaned/serviced. but will scan it today after work.

fired up ok with a slight stumble this morning but on lunch break back to the same long crank then fires perfectly fine after 3 second bs if anything is now detonating when that cranking is happening so not completely dead crank like yesterday before putting the cps in. hopefully my dme isnt shot. but then it wouldnt run good if the injector driver was failed. why only on starting?

maybe ill check the relay, friend might have a new one laying around his shop i could throw in too for the hell of it as a test.

just weird this is all happening ever since the battery died and a jump started it. i jump started it from the battery and didnt reverse polarity (would be having MUCH bigger problems) but doubt it spiked voltage and fried anything either as it would blow fuses/relays first before effecting anything. and its gotten progressively worse since that incident until this past week where long crank no matter what cold or hot start until i just put the CPS in it. saw a bit of oil seepage on the intake cam position sensor but its giving a good signal when i tested it. idk.

also noticed mileage discrepancy in the LKM and cluster when scanning it last night. off by almost 5,000 km... maybe lost sync or somethings up. ews has power on reset code but thats from just disconnecting battery when i replaced cps and a common fault.

code that wont delete is 94 [148] CAN DME/DDE, engine torque not adjustable.
then of course the BE [190] data-filing difference to the central light module.
have a few zke codes one for missing tilt sensor (never installed it when i did alarm install) and for a short circuit at motor tailgate (hear hatch throws that code sometimes, latch is crapping out)
also 90 [144] battery voltage: open circuit.

part out?

Last edited by Race M3; Tue, Oct-23-2018 at 08:36:15 PM.
Jump to top Race M3 is offline   Reply With Quote
Sponsored Links
Register now and remove these ads
Old Tue, Oct-23-2018, 11:50:06 PM   #22
Race M3
I can put whatever I want here?
 
Join Date: Jun 2014
Posts: 55
Reputation: 0 Race M3 is on a distinguished road
Location: Classified

United States




Default Re: Need help, hard start when vehicle warm runs flawlessly after.

Just pulled codes, nothing related returned yet...

Maybe I’ll just throw a fuel pressure regulator in it and see what happens. Wouldn’t hurt at 190k miles. They hold some residual pressure at the rail in these cars in addition to the fuel pump check valve, no? Fuel pressure seemed to hold when I tested it but idk...
Jump to top Race M3 is offline   Reply With Quote
Old Wed, Oct-24-2018, 02:18:41 AM   #23
CSLM3Wannabi
Registered User
 
Join Date: Mar 2018
Posts: 374
In the garage:
Reputation: 0 CSLM3Wannabi is on a distinguished road
Location: Fairfax

United States




Default Re: Need help, hard start when vehicle warm runs flawlessly after.

Quote:
Originally Posted by Race M3 View Post
Just pulled codes, nothing related returned yet...

Maybe Iíll just throw a fuel pressure regulator in it and see what happens. Wouldnít hurt at 190k miles. They hold some residual pressure at the rail in these cars in addition to the fuel pump check valve, no? Fuel pressure seemed to hold when I tested it but idk...
Just for sh*ts, disconnect the battery for an hour or even overnight. See how it starts the next morning and then scan right after and post codes please.
__________________
2005 BMW M3 ZCP Nardo Gray | ESS VT2-550 | Dinan Throttle Bodies | 6MT Swap | Active Autowerkes Headers + Section 1 w/ 100 cells | Miltek Section 2 and 3 | KW V2 w/ GC camber plates and Eibach Front and Rear Swaybars | Porsche 996 BBK upgrade w/ OEM ZCP rotors | Umnitza V4 Angel Eyes | Euro bumper w/ Morimoto led fogs | 1 piece Carbon Lip | VIS XTS Full carbon hood | SCZA Carbon Fiber CSL Trunk | Carbon Fiber CSL Diffuser | Square ZCP Wheels |
Jump to top CSLM3Wannabi is offline   Reply With Quote
Old Wed, Oct-24-2018, 03:32:33 AM   #24
Race M3
I can put whatever I want here?
 
Join Date: Jun 2014
Posts: 55
Reputation: 0 Race M3 is on a distinguished road
Location: Classified

United States




Default Re: Need help, hard start when vehicle warm runs flawlessly after.

Quote:
Originally Posted by CSLM3Wannabi View Post
Just for sh*ts, disconnect the battery for an hour or even overnight. See how it starts the next morning and then scan right after and post codes please.
Did that last night after crank sensor. But sure Iíll give it a go and report back.

Even cleaned contacts on battery cables and chassis...not a spec of corrosion on this m3.
Jump to top Race M3 is offline   Reply With Quote
Old Wed, Oct-24-2018, 12:59:45 PM   #25
Race M3
I can put whatever I want here?
 
Join Date: Jun 2014
Posts: 55
Reputation: 0 Race M3 is on a distinguished road
Location: Classified

United States




Default Re: Need help, hard start when vehicle warm runs flawlessly after.

update...

it did nothing.

ordered a fuel pressure regulator as its the only thing that hasnt been replaced fuel injection-wise. cant hurt with 189,000 original miles on it. last part im throwing at it. as the fpr DOES hold some residual pressure at the rail which is crucial for starting. pump is holding.

Last edited by Race M3; Wed, Oct-24-2018 at 03:56:29 PM.
Jump to top Race M3 is offline   Reply With Quote
Old Thu, Oct-25-2018, 03:08:01 AM   #26
Race M3
I can put whatever I want here?
 
Join Date: Jun 2014
Posts: 55
Reputation: 0 Race M3 is on a distinguished road
Location: Classified

United States




Default Re: Need help, hard start when vehicle warm runs flawlessly after.

Update. Installed new fuel pressure regulator. Car has noticeable more power from 5k to redline, but!


Still a long crank/hard start. Sh!t.

Iíve made my m3 run better than ever without fixing my root problem
Jump to top Race M3 is offline   Reply With Quote
Old Thu, Oct-25-2018, 04:16:31 AM   #27
CSLM3Wannabi
Registered User
 
Join Date: Mar 2018
Posts: 374
In the garage:
Reputation: 0 CSLM3Wannabi is on a distinguished road
Location: Fairfax

United States




Default Re: Need help, hard start when vehicle warm runs flawlessly after. DME faults

Same codes?


Sent from my iPhone using Tapatalk
__________________
2005 BMW M3 ZCP Nardo Gray | ESS VT2-550 | Dinan Throttle Bodies | 6MT Swap | Active Autowerkes Headers + Section 1 w/ 100 cells | Miltek Section 2 and 3 | KW V2 w/ GC camber plates and Eibach Front and Rear Swaybars | Porsche 996 BBK upgrade w/ OEM ZCP rotors | Umnitza V4 Angel Eyes | Euro bumper w/ Morimoto led fogs | 1 piece Carbon Lip | VIS XTS Full carbon hood | SCZA Carbon Fiber CSL Trunk | Carbon Fiber CSL Diffuser | Square ZCP Wheels |
Jump to top CSLM3Wannabi is offline   Reply With Quote
Old Thu, Oct-25-2018, 01:34:53 PM   #28
Winegums
Registered User
 
Winegums's Avatar
 
Join Date: Aug 2013
Age: 28
Posts: 2,160
In the garage:
Reputation: 0 Winegums is on a distinguished road
Location: Abbotsford, BC

Canada




Default Re: Need help, hard start when vehicle warm runs flawlessly after.

Have you tried checking all your power wires from the battery to your engine/starter?
__________________
"What's an M3, like a 328i or something?"
Jump to top Winegums is offline   Reply With Quote
Old Thu, Oct-25-2018, 09:53:00 PM   #29
Race M3
I can put whatever I want here?
 
Join Date: Jun 2014
Posts: 55
Reputation: 0 Race M3 is on a distinguished road
Location: Classified

United States




Default Re: Need help, hard start when vehicle warm runs flawlessly after.

Here’s a video from today after it sat for about 20 minutes. This honestly is the best it’s started all week and of course because I happened to be recording it...

Jump to top Race M3 is offline   Reply With Quote
Old Thu, Oct-25-2018, 11:47:43 PM   #30
WALKD_U
Registered User
 
WALKD_U's Avatar
 
Join Date: Apr 2011
Posts: 1,044
In the garage:
Reputation: 0 WALKD_U is on a distinguished road
Location: Madison

United States




Default Re: Need help, hard start when vehicle warm runs flawlessly after.

What is the temp outside?
__________________
Rides:
2005 AW/IR M3
BMB Stage 4
940whp/765wtq SAE Corrected

1996 BLU/BLK M3
NA Bolt-ons
235whp/225wtq SAE Corrected

Instagram:
M3HNGRY

EURO.techniks
<a href=https://www.instagram.com/m3hngry/ target=_blank>M3HNGRY</a>
Jump to top WALKD_U is offline   Reply With Quote
Reply

Bookmarks

Tags
dme, e46 m3, injector, no start, s54

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 07:58:04 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright ©1999-2017 M3Forum.com
Discussing Need help, hard start when vehicle warm runs flawlessly after. in the E46 M3 (2001-2006) Forum - Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006. at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)