BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > BMW M3 Discussions > E46 M3 (2001-2006)
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All Albums Garage Search Today's Posts Mark Forums Read Calendar FAQ

E46 M3 (2001-2006) Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006.


Reply
 
Thread Tools Display Modes
Old Tue, Sep-05-2017, 04:32:52 AM   #11
tomj87
Registered User
 
Join Date: Mar 2015
Posts: 6
Reputation: 0 tomj87 is on a distinguished road

United States




Default Re: knocking noise after cold start

Thanks for the feedback.

I agree with arehman, I think is is somehow related to the oil pump/pressure. The noise goes away as soon as the red oil pressure light goes out.

@e46hoonigan and e36sport: did u check/replace/rebuild the oilpump as well when u changed the rod bearings? Did the noise change after you replaced the rod bearings?

@Cuz5150: Good point! Thanks! I will check tomorrow how much oil I have left in my oil filter housing.

@redM3/4: red oil pressure light stays on for about 1-2 seconds. I watched a couple of videos on youtube when people start their M3s. It looks pretty much the same.

Thanks again for your help,
Tom
Jump to top tomj87 is offline   Reply With Quote
Sponsored Links
Register now and remove these ads
Old Tue, Sep-05-2017, 07:38:37 AM   #12
L0ADED
Registered User
 
L0ADED's Avatar
 
Join Date: Aug 2017
Posts: 571
Reputation: 0 L0ADED has disabled reputation
Location: The Coast

United States




Default Re: knocking noise after cold start

It seems like your M3 is slow to startup in regards to the revs. If the battery is weak, it can cause a slow startup and might not build oil pressure as fast as one with a good battery with high cold cranking amps. Some people say that it could be from the VANOS building oil pressure (especially on cold starts where the car has been sitting for a few days/weeks).
Jump to top L0ADED is offline   Reply With Quote
Old Tue, Sep-05-2017, 11:39:25 PM   #13
Arehman
Registered User
 
Arehman's Avatar
 
Join Date: Nov 2004
Posts: 1,666
In the garage:
Reputation: 0 Arehman is on a distinguished road
Location: Stone Mtn, GA

Pakistan




Default Re: knocking noise after cold start

Quote:
Originally Posted by tomj87 View Post
Thanks for the feedback.

I agree with arehman, I think is is somehow related to the oil pump/pressure. The noise goes away as soon as the red oil pressure light goes out.

@e46hoonigan and e36sport: did u check/replace/rebuild the oilpump as well when u changed the rod bearings? Did the noise change after you replaced the rod bearings?

@Cuz5150: Good point! Thanks! I will check tomorrow how much oil I have left in my oil filter housing.

@redM3/4: red oil pressure light stays on for about 1-2 seconds. I watched a couple of videos on youtube when people start their M3s. It looks pretty much the same.

Thanks again for your help,
Tom
OP does your car make this noise while driving? Or only on cold start?
__________________


2002 AW/IR 6spd coupe
Jump to top Arehman is online now   Reply With Quote
Old Thu, Sep-07-2017, 05:44:29 AM   #14
tomj87
Registered User
 
Join Date: Mar 2015
Posts: 6
Reputation: 0 tomj87 is on a distinguished road

United States




Default Re: knocking noise after cold start

@Arehman: no, the clicking only appears on cold starts. The clicking is completely gone as soon as the engine runs.

I uploaded a video:

Off topic: Btw, there is a "farting" noise (starting at second 8) which shows up from time to time. Does anyone knows what this is?

I opened my oil filter housing today. How much oil should be in this housing? There was probably 1" of oil in this housing.

Kind regards,
Thomas
Jump to top tomj87 is offline   Reply With Quote
Old Thu, Aug-30-2018, 03:08:37 PM   #15
zaharias
Registered User
 
Join Date: Jun 2015
Posts: 215
Reputation: 0 zaharias is on a distinguished road
Location: Chios/Greece

Greece




Default Re: knocking noise after cold start

Any updates here?
Did you find what was this sound at startup?
Jump to top zaharias is offline   Reply With Quote
Old Thu, Aug-30-2018, 11:25:42 PM   #16
stogybear
Registered User
 
stogybear's Avatar
 
Join Date: Jun 2015
Posts: 386
Reputation: 0 stogybear is on a distinguished road
Location: San Francisco

Armenia




Default Re: knocking noise after cold start

If I were to guess, I'd say it has something to do at the top of the engine. The reason the sound stops after a second or two is because oil gets to the top and muffles it. It might be a chain tensioner or something related to the chain.
__________________

2005 AW M3 - 6MT - Bay Area
Jump to top stogybear is offline   Reply With Quote
Old Fri, Aug-31-2018, 12:05:59 AM   #17
Cmamainer
Registered User
 
Join Date: Jul 2013
Posts: 46
In the garage:
Reputation: 0 Cmamainer is on a distinguished road
Location: Portland

United States




Default Re: knocking noise after cold start

I have exactly the same issue before and after installing all the Beisan upgrades, however on his rattle procedure, he recommends installing new S62 hub springs which i didn't do. I'm going to try this next.
Jump to top Cmamainer is offline   Reply With Quote
Old Fri, Aug-31-2018, 12:22:27 AM   #18
zaharias
Registered User
 
Join Date: Jun 2015
Posts: 215
Reputation: 0 zaharias is on a distinguished road
Location: Chios/Greece

Greece




Default Re: knocking noise after cold start

http://www.m3forum.net/m3forum/showp...1&postcount=26
Jump to top zaharias is offline   Reply With Quote
Old Wed, Nov-14-2018, 07:20:04 PM   #19
zaharias
Registered User
 
Join Date: Jun 2015
Posts: 215
Reputation: 0 zaharias is on a distinguished road
Location: Chios/Greece

Greece




Default Re: knocking noise after cold start

I think it's related to the oil pump..
Iam thinking of changing it in 2019.
Jump to top zaharias is offline   Reply With Quote
Old Fri, Nov-16-2018, 04:33:58 PM   #20
zaharias
Registered User
 
Join Date: Jun 2015
Posts: 215
Reputation: 0 zaharias is on a distinguished road
Location: Chios/Greece

Greece




Default Re: knocking noise after cold start

Sent my video to Raj (Beisan) and he told me "the cold startup rattle possibly being caused by a vanos solenoid valve body leaking valve."
Jump to top zaharias is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 09:08:35 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright 1999-2017 M3Forum.com
Discussing knocking noise after cold start in the E46 M3 (2001-2006) Forum - Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006. at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)