BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > BMW M3 Discussions > E46 M3 (2001-2006)
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All Albums Garage Search Today's Posts Mark Forums Read Calendar FAQ

E46 M3 (2001-2006) Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006.


Reply
 
Thread Tools Display Modes
Old Tue, Dec-04-2018, 05:59:13 PM   #41
Race M3
I can put whatever I want here?
 
Join Date: Jun 2014
Posts: 42
Reputation: 0 Race M3 is on a distinguished road
Location: Classified

United States




Default Re: Need help, hard start when vehicle warm runs flawlessly after.

no codes returned...still has the intermittent stumble on startup. has gotten better with cold weather now and does it less often. but it feels sluggish intermittently still then will rip when i hit the gas a second time...i give up lol.
Jump to top Race M3 is offline   Reply With Quote
Sponsored Links
Register now and remove these ads
Old Wed, Jan-23-2019, 03:42:56 PM   #42
Race M3
I can put whatever I want here?
 
Join Date: Jun 2014
Posts: 42
Reputation: 0 Race M3 is on a distinguished road
Location: Classified

United States




Default Re: Need help, hard start when vehicle warm runs flawlessly after.

Well, new ignition coils installed (eldor) now itís extremely fast...when it works

So far we have;

Vanos seals
Exhaust hub
Timing chain guides
Valve adjustment
Plugs
Coils
TPSís
ECT sensor
Crank sensor
Lubed/cleaned throttle actuator and throttle bodies
FPR and filter
Fuel injectors
Vanos solenoid repair and valve body cleaning

Now only fault codes I keep getting is a crankshaft position sensor and not triggering CEL/ shows not active fault when I have the hard start/long crank. Thing is I replaced it with a OE bmw sensor. Pinpoint test shows crank sensor is good.

Also have a fault for EGT sensor but thatís irrelevant. Had it since I bought it years ago.

Intermittent power loss still and screams every other throttle hit...

About to just sell it and get an e92.
Jump to top Race M3 is offline   Reply With Quote
Reply

Bookmarks

Tags
dme, e46 m3, injector, no start, s54

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 05:46:02 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright ©1999-2017 M3Forum.com
Discussing Need help, hard start when vehicle warm runs flawlessly after. in the E46 M3 (2001-2006) Forum - Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006. at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)