BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > BMW M3 Discussions > E46 M3 (2001-2006)
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All Albums Garage Search Today's Posts Mark Forums Read Calendar FAQ

E46 M3 (2001-2006) Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006.


Reply
 
Thread Tools Display Modes
Old Tue, Apr-28-2009, 03:29:33 PM   #31
Ghozt
Phuckface!!!!!
 
Ghozt's Avatar
 
Join Date: May 2007
Age: 35
Posts: 12,771
Reputation: 0 Ghozt is a glorious beacon of lightGhozt is a glorious beacon of light
Location: illadelph

United States




Default

First, my disclaimer is that I've done my homework with this, and would like to see if others who have had "similar" SMG issues can further validate what I'm thinking...

My car is about to lose its non-BMW warranty (70k+ miles on the vehicle) and I'd like to try my best to hit them with this expense should it be necessary, as everything on this car is covered, including all transmission parts...

I've had the SMG light come on from time to time... I don't launch ever, I wouldn't consider myself an overly aggressive driver... Rarely has the SMG lights appearance led to actual loss of gears...

However, whilst in Philly the other day, it was exceptionally hot (~95*) and my SMG light appears after driving around the city for a little, running some errands. A lot of stop and go, obviously...

Next thing I notice, upon a stop at a light, my car is moving me to '0' (or neutral) and I'm somewhat stranded in the middle of the road. Give the car a good 20-30 seconds and she gives me back 1st gear and I'm on my way... This happens a few times, and I make sure to take it extra easy, and I make it home safely over the bridge and back to NJ with no further issues. Turn the car off, and the next day, start her up and I have no SMG (gear) light and I never got the SES light like I have in the past... Car runs well... I'm no stranger to this, as it has happened before, but like I said, typically never the loss of gears...

So, my question for you past and current SMG trouble guys, are we most likey looking at the pump?

I fear that's what it is, after doing my research, but I almost don't want to believe it. I've placed an order for a new relay, and I'm going to start there. But I don't DD this car, and I worry that if I wait, and wait, and the issue masks itself as gone, and then suddenly reappears, I won't be able to get my warranty company to foot the bill...

Thanks in advance for any help, advice... This thread alone was truly helpful...
__________________
Jump to top Ghozt is offline   Reply With Quote
Sponsored Links
Register now and remove these ads
Old Tue, Apr-28-2009, 04:11:37 PM   #32
Mash3
Look out below!
 
Join Date: Aug 2003
Age: 48
Posts: 7,311
Reputation: 0 Mash3 is a jewel in the rough
Location: Hollywierd

United States




Default

Quote:
Originally Posted by GhostM3JP View Post

So, my question for you past and current SMG trouble guys, are we most likey looking at the pump?

Doubtful.

What is the level of the fluid in the SMG reservoir?

It may have overheated, which could be caused by low fluid level (fluid is a coolant, too).
__________________
http://www.m3forum.net/gallery/data/522/medium/Willow_.jpg
Forum Member Since 2003.
. . 2004 M3, SG/ IR. 95k miles. Original owner.
Jump to top Mash3 is offline   Reply With Quote
Old Tue, Apr-28-2009, 04:20:08 PM   #33
m3 hal
Registered User
 
Join Date: Jan 2006
Posts: 21,172
Reputation: 0 m3 hal will become famous soon enough

United States




Default

Quote:
Originally Posted by Mash3 View Post
Doubtful.

What is the level of the fluid in the SMG reservoir?

It may have overheated, which could be caused by low fluid level (fluid is a coolant, too).
yup, check that first
Jump to top m3 hal is offline   Reply With Quote
Old Tue, Apr-28-2009, 04:55:49 PM   #34
Ghozt
Phuckface!!!!!
 
Ghozt's Avatar
 
Join Date: May 2007
Age: 35
Posts: 12,771
Reputation: 0 Ghozt is a glorious beacon of lightGhozt is a glorious beacon of light
Location: illadelph

United States




Default

Thanks guys. Will check when I get home from work...
__________________
Jump to top Ghozt is offline   Reply With Quote
Old Wed, Jun-24-2009, 10:57:48 PM   #35
bmw_for_life
Registered User
 
Join Date: Jun 2009
Posts: 24
Reputation: 0 bmw_for_life is on a distinguished road

United States




Default

Hello,

I am from Romania and i am having some problems with a bmw m3 e46 from 2002.it has a smg2 gearbox.the problem i am facing is that the car switches from any gear i am in to 0 or N point and that thing is happening while i am driving the car.i have the gearbox light on and the engine light as well on my odometer.i need to mention that i replaced the relay 3 weeks ago.also when i am in the 3th gear for example and the trothle is at almost 3000 rpm or 4000 rpm and i take the foot off the acceleration it feels inside just like the clutch automatically disable and the rpm odometer declines with almost 500 rpm and when i put the foot again on the gas pedal i can feel the clutch instantly working and it gives a kind of shock in the car.my problem is very important because i could not drive the car today at all because when the oil temperature reaches almost 100 C it automatically switches from the gear i am in at that moment to N and the car stops.it is showing me from the position of the gearbox stick that the car is in gear but in the same time it is on N position.I have ecperienced this today several times and the car stops in the traffic.i was with it at bmw dealer in my town and they replaced me the smg pump but now i cannot drive it at all and it is more broken that was before.it can be the smg fluid?i have checked it and the level is o.k.the guys from bmw told me that they also took the air off the instalation.what can i do as i need the car to leave in holliday in 2 days from now.
please help me!! :-)((
Jump to top bmw_for_life is offline   Reply With Quote
Old Sat, Jul-04-2009, 07:25:36 AM   #36
jyrbba
Registered User
 
Join Date: Jul 2009
Posts: 25
Reputation: 0 jyrbba is on a distinguished road

United States




Default

Got a very similar problem as the post above. The car works for a while, but after ~2-3hrs of intense driving SMG(gear) and engine lights lid up. I've checked the error memory for both engine and smg and they always come up with the same errors (BMW INPA).

177 - Mil external info
Mil requirement by SMG
Error present
Static Error

------------------------

56 - Switching on time of hydralic unit
Implausible value
sporadic error

That doesn't really mean s**t to me. I already swapped the relay, and almost thought it fixed when, worked well for almost 3 hours of hard city circuit But then BOOM lights up and dropping out of gears to N/0.

Sounds just too weird to be the pump, since it works great until it actually starts working bad I've checked the smg fluid, and it was like ~70% to the max line, and the car had been sitting for few days. Is this normal? Cause imo the problem seems to happen when the car heats up properly.

Here is the exact error codes if anyone is interested:

------------------------

56 Switching-on time of hydraulic unit

Error Frequency : 1

Error Occured 1. times at:

Current kilometres 90950.00 km
environmental temperature 14.00 grad C
Voltage supply Ubatt 13.00 V
Hydraulic pump state 1.00 0/1
actual hydraulic temperature 76.00 grad C
hydraulic pressure of raw data 79,63 bar
clutch state 1.0 closed
gearbox state 0.00 shifted
engine speed by CAN 2108.00 1/min
sensor voltage supply B 5.01 V

------------------------

And engine...

------------------------

177 Mil external info

Error frequency: 1
logistic counter: 40

Engine speed 960.00 rpm
relative filling 12.00 %
cooling water temp 85.00 degrees C
Lambda adaptation offset 1.82 ms
aufgetreten vor (rel. BZ) 0.10 h

MIL-requirement by SMG
Error Present
Static Error

Ideas anyone?
Jump to top jyrbba is offline   Reply With Quote
Old Sat, Jul-04-2009, 02:31:54 PM   #37
jyrbba
Registered User
 
Join Date: Jul 2009
Posts: 25
Reputation: 0 jyrbba is on a distinguished road

United States




Default

Found out the problem (most likely). The Hose under the reservoir was leaking, does anyone have a diy for swapping it to a new one?

Or if someone can just tell me if it needs to be bled after replacing?

I think the part is this one?

03 Connecting line 21532282255 $25.07
Jump to top jyrbba is offline   Reply With Quote
Old Sat, Jul-04-2009, 04:04:29 PM   #38
Blown_m3
Always want more boost!
 
Blown_m3's Avatar
 
Join Date: Feb 2008
Posts: 1,587
Reputation: 0 Blown_m3 is on a distinguished road
Location: SA Town, Texas

United States




Default

Smg fluid should be checked every 2-3k miles. Just to be on the safe side. pentosin
cf11s
__________________
Sold 2002 BMW ///M3 SMG - Steel gray, AA Gen 2 Level 3+ Meth ///HPF stage1 clutch and AA lwFW, CSL brakes///M 2x2 cf Interior,Vors CF Roof with sunroof, CSL Bumper,Diffuser,GC coilovers,Volks/Rayz(ROJA)Wheels w/ Michelin PS2 245/35/19 & 275/30/19, Powerflex RTAB, rouge transmission mounts, Unmitza Angle eys and 8000k HID, AA headers and AA Gen IV exhaust,HardWired V1, Dynavin:v5, JL audio Custom 1 w3v3 ported & 500/5 Amp/AudioControl DQX, lts2.
Jump to top Blown_m3 is offline   Reply With Quote
Old Sat, Jul-04-2009, 05:17:33 PM   #39
jyrbba
Registered User
 
Join Date: Jul 2009
Posts: 25
Reputation: 0 jyrbba is on a distinguished road

United States




Default

Quote:
Originally Posted by Blown_m3 View Post
Smg fluid should be checked every 2-3k miles. Just to be on the safe side. pentosin
cf11s
I know which fluid it is, since it says it on the cap. I just don't want to add fluid to a leaking system. So again, waiting for any helps for swapping out the connecting line between reservoir and pump.

-Jyri
Jump to top jyrbba is offline   Reply With Quote
Old Mon, Jul-06-2009, 05:28:54 PM   #40
scottn2retro
Into things retro
 
scottn2retro's Avatar
 
Join Date: Mar 2002
Posts: 422
Reputation: 0 scottn2retro has disabled reputation
Location: Huntington Beach





Default

This is a great thread - could have used this back in 2006.

Back in 2006, we had a problem with delayed upshifts. We tried a lot of things and then we took a chance and swapped in an SMG contol module from another car just for a test drive and that turned out to be the problem. Very hard to diagnose, because one of the units that might give you useful error information was itself the problem. We don't know why the SMG control module was the problem or what may be wrong with it (I still have it in a box), but changing it solved the problem.

So something that maybe could be added to the original post for a troubleshooting method is trying an SMG control module from another car if available. You won't be able to drive the car full speed (unless you re-program it, but then you'd need to re-program it back for the original car), but it may let you see if the behavior changes or not.

Last edited by scottn2retro; Wed, Jul-08-2009 at 02:57:39 AM.
Jump to top scottn2retro is offline   Reply With Quote
Reply

Bookmarks

Tags
faq, smg, troubleshooting

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubleshooting Codes AirDoc E36 M3 (1992-1999) 0 Sat, Nov-17-2007 03:49:53 AM
Troubleshooting a problem ----> HELP ! RoadShreader E36 M3 (1992-1999) 43 Sun, Dec-31-2006 07:05:57 PM
Eclipse Troubleshooting crazy32184 E36 M3 (1992-1999) 7 Thu, Jun-09-2005 07:03:15 AM
HELP PLEASE!!! Troubleshooting my ///M! M3nEwBoOtY E36 M3 (1992-1999) 6 Sun, Apr-03-2005 04:37:52 PM



All times are GMT. The time now is 04:57:42 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright 1999-2017 M3Forum.com
Discussing SMG troubleshooting FAQ in the E46 M3 (2001-2006) Forum - Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006. at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)