BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > BMW M3 Discussions > E46 M3 (2001-2006)
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All Albums Garage Search Today's Posts Mark Forums Read Calendar FAQ

E46 M3 (2001-2006) Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006.


Reply
 
Thread Tools Display Modes
Old Wed, Jan-09-2019, 07:40:42 AM   #1
berto
Registered User
 
Join Date: Jun 2011
Posts: 41
In the garage:
Reputation: 0 berto is on a distinguished road

United States




Default Help please, smg wont display, crank but no start

hi guys, i recently changed headers on my 03 and put everything back in place reconnected the battery and tried to start her up, the gear display on the dash is not showing any numbers she cracks but does not fire up. i checked all the wires and the engine ground to chassis all is connected, checked fuses and relays all is well fuel pump primes SMG pump primes but no start. searched most threads cant seem to find an answer. i have owned this car for almost 11 years now faced almost all m3 issues but this is a first.
also and this is weird but its cranking without needing to press on the breaks.

Last edited by berto; Wed, Jan-09-2019 at 08:17:10 AM.
Jump to top berto is offline   Reply With Quote
Sponsored Links
Register now and remove these ads
Old Wed, Jan-09-2019, 01:21:26 PM   #2
atsantone
Registered User
 
Join Date: Apr 2014
Posts: 144
Reputation: 0 atsantone is on a distinguished road

United States




Default Re: Help please, smg wont display, crank but no start

Hard to say what happened here, but, start with the easy stuff first. Check and
Clear codes then perform a dme/ews alignment(even though it cranks..).
Any codes that reappear will likely be the culprits.
Anthony
Jump to top atsantone is offline   Reply With Quote
Old Wed, Jan-09-2019, 04:53:11 PM   #3
Mr.wReckless
Registered User
 
Mr.wReckless's Avatar
 
Join Date: Dec 2018
Posts: 56
Reputation: 0 Mr.wReckless is on a distinguished road

Norway




Default Re: Help please, smg wont display, crank but no start

Following as I am changing headers too ATM. I have noticed I haven’t got a gear display either but I’ve got the salmon relay pulled to save battery from unneccessary priming whilst I work on the car during winter storage.

Out of curiousness, have you checked the fuel pump fuse in the glove compartment?

Regards
Jump to top Mr.wReckless is offline   Reply With Quote
Old Fri, Jan-11-2019, 04:19:34 PM   #4
berto
Registered User
 
Join Date: Jun 2011
Posts: 41
In the garage:
Reputation: 0 berto is on a distinguished road

United States




Default Re: Help please, smg wont display, crank but no start

Thx Anthony, i couldnt get my ha ds on a diagnostic tool yet ill scan and check the codes
Jump to top berto is offline   Reply With Quote
Old Fri, Jan-11-2019, 04:23:37 PM   #5
berto
Registered User
 
Join Date: Jun 2011
Posts: 41
In the garage:
Reputation: 0 berto is on a distinguished road

United States




Default Re: Help please, smg wont display, crank but no start

Quote:
Originally Posted by Mr.wReckless View Post
Following as I am changing headers too ATM. I have noticed I havenít got a gear display either but Iíve got the salmon relay pulled to save battery from unneccessary priming whilst I work on the car during winter storage.

Out of curiousness, have you checked the fuel pump fuse in the glove compartment?

Regards
I tried my backup salmon relay ... nothing same issue no numbers on the display
So its not that. Checked the fuel pump fuse its good fuel pump primes just fine.
Its driving me crazy, mayb its in safe mode or something i dont know i guess i need to scan it and see.
Jump to top berto is offline   Reply With Quote
Old Fri, Jan-11-2019, 04:31:22 PM   #6
Texaz3
Registered User
 
Join Date: Dec 2015
Posts: 1,789
Reputation: 0 Texaz3 is on a distinguished road

United States




Default Re: Help please, smg wont display, crank but no start

Do you hear smg pump prime when you open the door?
Jump to top Texaz3 is offline   Reply With Quote
Old Fri, Jan-11-2019, 04:32:56 PM   #7
Mr.wReckless
Registered User
 
Mr.wReckless's Avatar
 
Join Date: Dec 2018
Posts: 56
Reputation: 0 Mr.wReckless is on a distinguished road

Norway




Default Re: Help please, smg wont display, crank but no start

I hear a lot of talk about GPS (gear position sensor), could a compete faulty sensor, or perhaps disconnected one be the culprit of a "no gear display" symptom?

Other suggestions would be hood latch sensors, as well as I suspect the brake pedal has to be pressed for the SMG to change into neutral so perhaps a potential fault there too?

Just spitballin' scapegoats here, but they may herd somewhere else AFAIK.

Regards
Jump to top Mr.wReckless is offline   Reply With Quote
Old Fri, Jan-11-2019, 04:33:37 PM   #8
Mr.wReckless
Registered User
 
Mr.wReckless's Avatar
 
Join Date: Dec 2018
Posts: 56
Reputation: 0 Mr.wReckless is on a distinguished road

Norway




Default Re: Help please, smg wont display, crank but no start

Quote:
Originally Posted by Texaz3 View Post
Do you hear smg pump prime when you open the door?
In the OP he says it does.

Regards
Jump to top Mr.wReckless is offline   Reply With Quote
Old Sat, Jan-12-2019, 07:21:53 AM   #9
berto
Registered User
 
Join Date: Jun 2011
Posts: 41
In the garage:
Reputation: 0 berto is on a distinguished road

United States




Post Re: Help please, smg wont display, crank but no start

Quote:
Originally Posted by Mr.wReckless View Post
I hear a lot of talk about GPS (gear position sensor), could a compete faulty sensor, or perhaps disconnected one be the culprit of a "no gear display" symptom?

Other suggestions would be hood latch sensors, as well as I suspect the brake pedal has to be pressed for the SMG to change into neutral so perhaps a potential fault there too?

Just spitballin' scapegoats here, but they may herd somewhere else AFAIK.

Regards
i dont think its the hood latch we are not there yet i just need her to start first
it could be the GPS, but its engaging gears fine i can hear it from under the car. could it be some kind of safe mode i dont know about ???
i mean it cranks fine all pumps prime all is well if i shit the gear nob to first or put it in reverse it wont crank until i shift back to neutral which means the gears are engaging fine...
Jump to top berto is offline   Reply With Quote
Old Sat, Jan-12-2019, 03:47:11 PM   #10
Pnick
Registered User
 
Pnick's Avatar
 
Join Date: Oct 2012
Posts: 854
Reputation: 0 Pnick is on a distinguished road
Location: Jax

United States




Default Re: Help please, smg wont display, crank but no start

Cranking but no start is not related to SMG. If you have SMG issues, it will not crank at all.
Look for no start issues somewhere else...maybe related to the header replacement (any ground wire/s you disconnected in the engine bay?).

Fuel, Spark, Compression all when properly timed = start?.
__________________

05-SMG/IB/CINN/ZCP/SUNROOF_DELETE
If they don't meet your standards, lower yours!
Jump to top Pnick is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 08:31:46 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright ©1999-2017 M3Forum.com
Discussing Help please, smg wont display, crank but no start in the E46 M3 (2001-2006) Forum - Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006. at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)