BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > BMW M3 Discussions > E46 M3 (2001-2006)
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All Albums Garage Search Today's Posts Mark Forums Read Calendar FAQ

E46 M3 (2001-2006) Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006.


Reply
 
Thread Tools Display Modes
Old Thu, Jan-10-2019, 09:28:29 PM   #21
jayyym3
Registered User
 
Join Date: Feb 2018
Posts: 34
Reputation: 0 jayyym3 is on a distinguished road

United States




Default Re: Cranks but does not start

No longer a fuel related issue. Fuel is going to the engine but there is no spark. I replaced the spark plugs and CPS. I ordered one from Oreilys which ended up being a BMW OEM part for half of the price. I'm now trying out a DME relay today after work. Not sure of anything else that would cause a spark issue.
Jump to top jayyym3 is offline   Reply With Quote
Sponsored Links
Register now and remove these ads
Old Thu, Jan-10-2019, 10:54:15 PM   #22
ThunderMoose
Registered User
 
Join Date: Dec 2011
Posts: 2,771
In the garage:
Reputation: 0 ThunderMoose is on a distinguished road
Location: Gonzales

United States




Default Re: Cranks but does not start

Quote:
Originally Posted by jayyym3 View Post
No longer a fuel related issue. Fuel is going to the engine but there is no spark. I replaced the spark plugs and CPS. I ordered one from Oreilys which ended up being a BMW OEM part for half of the price. I'm now trying out a DME relay today after work. Not sure of anything else that would cause a spark issue.
How are you checking for spark?
__________________


#67 2017 NASA TX TT3 Champion

FLMS Half Cage, RaceTech 4009HR drivers seat, Schroth 6-Pt Harness, E.S.S. Fire System, AIM SOLO DL with ECU Harness, SmartyCam, Angle Aluminum with VAC dead pedal, Sparco Steering Wheel on MOMO hub, MCS Suspension, Hyperco 800F 900R springs, Hotchkis Front and Rear Sway bars, Vorshlag Camber Plates, Turner ARCA, AJ Hartman Front Splitter, BW V2 Wing, BW CF Rear Diffuser, APEX ARC-8 wheels, Brembo BBK Front, Carbon Fiber Roof, CF Headlight Blanks, Door Windows and Cards Delete, TMS rear and front subframe reinforcement, Zionsville Competition Cooler, BW Oil Cooler, Oil Diverter Valve, Motorsports Thermostat, Evolve CF Intake, Epic Stepped Headers, Turner Pulleys, BW 3.5" Race Exhaust, EPIC Alpha N Tune, Beisan Oil Disk and Vanos Seals, ZF 5MT, CAE Ultra Shifter

My track journal: http://www.m3forum.net/m3forum/showthread.php?t=509148
Jump to top ThunderMoose is offline   Reply With Quote
Old Fri, Jan-11-2019, 05:20:45 AM   #23
jayyym3
Registered User
 
Join Date: Feb 2018
Posts: 34
Reputation: 0 jayyym3 is on a distinguished road

United States




Default Re: Cranks but does not start

Quote:
Originally Posted by ThunderMoose View Post
How are you checking for spark?
I tested it again and got spark this time. I wasnt grounding the spark plug correctly. So Iím getting fuel and spark at this point so not sure what to do next.
Jump to top jayyym3 is offline   Reply With Quote
Old Fri, Jan-11-2019, 05:57:05 AM   #24
mrgizmo04
Registered User
 
mrgizmo04's Avatar
 
Join Date: Jan 2017
Posts: 2,964
In the garage:
Reputation: 0 mrgizmo04 is on a distinguished road
Location: Menlo Park

United States




Default Re: Cranks but does not start

Quote:
Originally Posted by jayyym3 View Post
I tested it again and got spark this time. I wasnt grounding the spark plug correctly. So Iím getting fuel and spark at this point so not sure what to do next.
Crank/cam/maf sensors?

Sent from my SM-G950U using Tapatalk
__________________
'85 528e 164k miles (sold)
'05 M3 6MT coupe

All DIY: VANOS, WPC rod bearings, full SS (SS stepped V1 headers, catted S1, stock S2, SS sport), AFD E85 Proflex kit, Ohlins R&T/Hyperco 375f Swift 672r/GC street tops and camber plates, ST40 355 pfc08, 330 ZHP steering rack, diffsonline 4.1 diff with rem polish, E60 short shifter lever, AKG black diff bushings/subframe bushings, Rogue rtab, Sachs clutch/flywheel, rear main, Beyer driveshaft, valve adjustment, cooling refresh.

Happy to help with VANOS or any other DIY job around NorCal. Have various specialty tools (VANOS, RTAB, engine bar, valve adjustment, tranny jack, ball joint separator, pilot bearing puller, tap&die kit, etc).
Jump to top mrgizmo04 is offline   Reply With Quote
Old Fri, Jan-11-2019, 12:00:15 PM   #25
ThunderMoose
Registered User
 
Join Date: Dec 2011
Posts: 2,771
In the garage:
Reputation: 0 ThunderMoose is on a distinguished road
Location: Gonzales

United States




Default Re: Cranks but does not start

Quote:
Originally Posted by jayyym3 View Post
I tested it again and got spark this time. I wasnt grounding the spark plug correctly. So Iím getting fuel and spark at this point so not sure what to do next.


Iíd do a leak down test and make sure thereís not an issue with compression.

Then I would look at vanos operation. Easiest thing to do is remove and clean the vanos solenoid body.

You can also pop the end cap of the intake cam. That piston should be in about 5-10 mm with the car off. In my experience if vanos is not operating properly, it will prevent engine from catching.


Sent from my iPhone using Tapatalk
__________________


#67 2017 NASA TX TT3 Champion

FLMS Half Cage, RaceTech 4009HR drivers seat, Schroth 6-Pt Harness, E.S.S. Fire System, AIM SOLO DL with ECU Harness, SmartyCam, Angle Aluminum with VAC dead pedal, Sparco Steering Wheel on MOMO hub, MCS Suspension, Hyperco 800F 900R springs, Hotchkis Front and Rear Sway bars, Vorshlag Camber Plates, Turner ARCA, AJ Hartman Front Splitter, BW V2 Wing, BW CF Rear Diffuser, APEX ARC-8 wheels, Brembo BBK Front, Carbon Fiber Roof, CF Headlight Blanks, Door Windows and Cards Delete, TMS rear and front subframe reinforcement, Zionsville Competition Cooler, BW Oil Cooler, Oil Diverter Valve, Motorsports Thermostat, Evolve CF Intake, Epic Stepped Headers, Turner Pulleys, BW 3.5" Race Exhaust, EPIC Alpha N Tune, Beisan Oil Disk and Vanos Seals, ZF 5MT, CAE Ultra Shifter

My track journal: http://www.m3forum.net/m3forum/showthread.php?t=509148
Jump to top ThunderMoose is offline   Reply With Quote
Old Fri, Jan-11-2019, 04:14:46 PM   #26
jayyym3
Registered User
 
Join Date: Feb 2018
Posts: 34
Reputation: 0 jayyym3 is on a distinguished road

United States




Default Re: Cranks but does not start

Quote:
Originally Posted by mrgizmo04 View Post
Crank/cam/maf sensors?

Sent from my SM-G950U using Tapatalk
Crank was already replaced. I saw most cam issues cause a engine light to go on. I had a bad maf once before. It would crank and stark for a second or two before stalling. Now it just cranks and doesnt start with or without the MAF connected.
Jump to top jayyym3 is offline   Reply With Quote
Old Fri, Jan-11-2019, 04:16:54 PM   #27
jayyym3
Registered User
 
Join Date: Feb 2018
Posts: 34
Reputation: 0 jayyym3 is on a distinguished road

United States




Default Re: Cranks but does not start

Quote:
Originally Posted by ThunderMoose View Post
Iíd do a leak down test and make sure thereís not an issue with compression.

Then I would look at vanos operation. Easiest thing to do is remove and clean the vanos solenoid body.

You can also pop the end cap of the intake cam. That piston should be in about 5-10 mm with the car off. In my experience if vanos is not operating properly, it will prevent engine from catching.


Sent from my iPhone using Tapatalk
The car was running fine. Not sluggish or problematic prior it to dying while running. Would this be an indicator that the vanos is fine. I was thinking that the bump on the road loosened something.
Jump to top jayyym3 is offline   Reply With Quote
Old Fri, Jan-11-2019, 04:33:31 PM   #28
mrgizmo04
Registered User
 
mrgizmo04's Avatar
 
Join Date: Jan 2017
Posts: 2,964
In the garage:
Reputation: 0 mrgizmo04 is on a distinguished road
Location: Menlo Park

United States




Default Re: Cranks but does not start

Vanos, even if broken, will get stuck in one position rather than dynamically update timing, but the car should still run, albeit kind of rough in a certain rpm range.

Sent from my SM-G950U using Tapatalk
__________________
'85 528e 164k miles (sold)
'05 M3 6MT coupe

All DIY: VANOS, WPC rod bearings, full SS (SS stepped V1 headers, catted S1, stock S2, SS sport), AFD E85 Proflex kit, Ohlins R&T/Hyperco 375f Swift 672r/GC street tops and camber plates, ST40 355 pfc08, 330 ZHP steering rack, diffsonline 4.1 diff with rem polish, E60 short shifter lever, AKG black diff bushings/subframe bushings, Rogue rtab, Sachs clutch/flywheel, rear main, Beyer driveshaft, valve adjustment, cooling refresh.

Happy to help with VANOS or any other DIY job around NorCal. Have various specialty tools (VANOS, RTAB, engine bar, valve adjustment, tranny jack, ball joint separator, pilot bearing puller, tap&die kit, etc).
Jump to top mrgizmo04 is offline   Reply With Quote
Old Fri, Jan-11-2019, 06:01:35 PM   #29
ThunderMoose
Registered User
 
Join Date: Dec 2011
Posts: 2,771
In the garage:
Reputation: 0 ThunderMoose is on a distinguished road
Location: Gonzales

United States




Default Re: Cranks but does not start

Quote:
Originally Posted by jayyym3 View Post
The car was running fine. Not sluggish or problematic prior it to dying while running. Would this be an indicator that the vanos is fine. I was thinking that the bump on the road loosened something.


Well it could be a head gasket, but Iíd try the other stuff first.


Sent from my iPhone using Tapatalk
__________________


#67 2017 NASA TX TT3 Champion

FLMS Half Cage, RaceTech 4009HR drivers seat, Schroth 6-Pt Harness, E.S.S. Fire System, AIM SOLO DL with ECU Harness, SmartyCam, Angle Aluminum with VAC dead pedal, Sparco Steering Wheel on MOMO hub, MCS Suspension, Hyperco 800F 900R springs, Hotchkis Front and Rear Sway bars, Vorshlag Camber Plates, Turner ARCA, AJ Hartman Front Splitter, BW V2 Wing, BW CF Rear Diffuser, APEX ARC-8 wheels, Brembo BBK Front, Carbon Fiber Roof, CF Headlight Blanks, Door Windows and Cards Delete, TMS rear and front subframe reinforcement, Zionsville Competition Cooler, BW Oil Cooler, Oil Diverter Valve, Motorsports Thermostat, Evolve CF Intake, Epic Stepped Headers, Turner Pulleys, BW 3.5" Race Exhaust, EPIC Alpha N Tune, Beisan Oil Disk and Vanos Seals, ZF 5MT, CAE Ultra Shifter

My track journal: http://www.m3forum.net/m3forum/showthread.php?t=509148
Jump to top ThunderMoose is offline   Reply With Quote
Old Sat, Jan-12-2019, 07:27:18 AM   #30
berto
Registered User
 
Join Date: Jun 2011
Posts: 41
In the garage:
Reputation: 0 berto is on a distinguished road

United States




Default Re: Cranks but does not start

Quote:
Originally Posted by jayyym3 View Post
You should hear the SMG pump prime when you unlock/open your car. I'm still able to switch between neutral and 1st gear. If yours isnt doing this then look into the salmon relay.
yeah im good on that its engaging fine fine but nothing on the display. i used my back up salmon relay that was not the issue i can hear it changing gears fine from underneath all the pumps prime well all the fuses are in check ... driving me crazy!!! could it be some sort of safe mode i dont know about?
Jump to top berto is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 08:40:58 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright ©1999-2017 M3Forum.com
Discussing Cranks but does not start in the E46 M3 (2001-2006) Forum - Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006. at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)