BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > BMW M3 Discussions > E46 M3 (2001-2006)
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All Albums Garage Search Today's Posts Mark Forums Read Calendar FAQ

E46 M3 (2001-2006) Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006.


Reply
 
Thread Tools Display Modes
Old Sat, Jan-05-2019, 03:14:07 AM   #11
wichonewichone
Registered User
 
Join Date: Jul 2018
Posts: 71
Reputation: 0 wichonewichone is on a distinguished road

United States




Default Re: Cranks but does not start

Quote:
Originally Posted by terraphantm View Post
Crankshaft sensor maybe


Would imagine that would throw a code


Sent from my iPhone using Tapatalk
Jump to top wichonewichone is online now   Reply With Quote
Sponsored Links
Register now and remove these ads
Old Sat, Jan-05-2019, 04:07:03 AM   #12
bmwe46nyc
Registered User
 
Join Date: Apr 2007
Posts: 134
Reputation: 0 bmwe46nyc is on a distinguished road
Location: Boogie Down

United States




Default Re: Cranks but does not start

I was not not throwing any codes hence the headaches....but step by step I figured that it wasn’t fuel pump, then changing sensor here and there, fuel filter, fuel filter bar, injectors, spark plugs etc then I changed o2 sensors and temp sensor and gucci


Sent from my iPhone using Tapatalk
Jump to top bmwe46nyc is offline   Reply With Quote
Old Sat, Jan-05-2019, 08:33:19 PM   #13
TboneM3
YNWA
 
TboneM3's Avatar
 
Join Date: Oct 2009
Posts: 8,319
In the garage:
Reputation: 0 TboneM3 is on a distinguished road
Location: Socal

United States




Default Re: Cranks but does not start

What?
__________________
/// 2004 SilberGrau M3 · Coupe · 6MT · slicktop · manual seats · zero options · ~3200lbs · JOURNAL
_


Evolve-R Alpha N · Evolve CSL CF Airbox · Eventuri Scoop · Supersprint V1 stepped 2.5" · SS V1 S pipes 2.5" + 200 cell HFC · OE sect 2 · SCZA 2.5" sect 3 · Besian · RE pullies · WPC'd OE bearings · oil catch can · fan/SAP/washer delete · CSL battery

GroundControl S/A Koni (Hyperco/Eibach 300/550) + tall RSMs · Hotchkis front sway (med) · rear strut bar · TMS camber & subframe plates · SPC alum rear camber arms · RE trans mounts · AKG poly subf/diff 95a · SDW RTAB · weighted ///M knob + ZHP alcantara boot + UUC DSSR + delrin bushing · Mason clutch pedal + brass bushing · TMS black pedals · delrin brake pedal bushing

OE CSL trunk · Sportline 8S 18"x8.5/9.5" · MPSS 245/275 · APEX 75mm Studs · 12mm/10mm F/R spacers · Brembo 996 4 pot 36/40 345mm CSL & 28/30 328mm CSL · ZHP "712" rack · Pioneer/CDT/Eclipse/Kicker
Jump to top TboneM3 is offline   Reply With Quote
Old Sat, Jan-05-2019, 08:56:40 PM   #14
mrgizmo04
Registered User
 
mrgizmo04's Avatar
 
Join Date: Jan 2017
Posts: 2,693
In the garage:
Reputation: 0 mrgizmo04 is on a distinguished road
Location: Menlo Park

United States




Default Re: Cranks but does not start

Lol, so it was a bad gucci?

Sent from my SM-G950U using Tapatalk
__________________
'85 528e 164k miles (sold)
'05 M3 6MT coupe

All DIY: VANOS, WPC rod bearings, full SS (SS stepped V1 headers, catted S1, stock S2, SS sport), AFD E85 Proflex kit, Ohlins R&T/Swift 448f 672r/GC street tops and camber plates, 330 ZHP steering rack, diffsonline 4.1 diff with rem polish, E60 short shifter lever, AKG black diff bushings/subframe bushings, Rogue rtab, Sachs clutch/flywheel, rear main, Beyer driveshaft, valve adjustment, cooling refresh.

Happy to help with VANOS or any other DIY job around NorCal
Jump to top mrgizmo04 is online now   Reply With Quote
Old Sat, Jan-05-2019, 09:22:00 PM   #15
11b4
Registered User
 
11b4's Avatar
 
Join Date: Jan 2016
Posts: 937
Reputation: 0 11b4 is on a distinguished road

United States




Default Re: Cranks but does not start

I hate when the Gucci goes bad.

Sent from my SM-G935V using Tapatalk
Jump to top 11b4 is offline   Reply With Quote
Old Wed, Jan-09-2019, 07:54:15 AM   #16
berto
Registered User
 
Join Date: Jun 2011
Posts: 29
In the garage:
Reputation: 0 berto is on a distinguished road

United States




Default Re: Cranks but does not start

hey whats Gucci ? and did the car start?
i am having a similar issue now also i am not getting any numbers on the gear display on the dash board so i am thinking its an SMG issue but i ran most diagnostics and checked most fuses i and cant seem to get it to start. its weird she even cranks without pressing on the break !!
Jump to top berto is offline   Reply With Quote
Old Wed, Jan-09-2019, 12:46:54 PM   #17
bmwe46nyc
Registered User
 
Join Date: Apr 2007
Posts: 134
Reputation: 0 bmwe46nyc is on a distinguished road
Location: Boogie Down

United States




Default Re: Cranks but does not start

Quote:
Originally Posted by berto View Post
hey whats Gucci ? and did the car start?
i am having a similar issue now also i am not getting any numbers on the gear display on the dash board so i am thinking its an SMG issue but i ran most diagnostics and checked most fuses i and cant seem to get it to start. its weird she even cranks without pressing on the break !!


Lol....Gucci is slang for like perfect.....meaning that when I changed my air temp sensor under manifold and all of o2 sensors that solved my problem. But for me I think it was the o2 sensors.....


Sent from my iPhone using Tapatalk
Jump to top bmwe46nyc is offline   Reply With Quote
Old Wed, Jan-09-2019, 01:38:32 PM   #18
ThunderMoose
Registered User
 
Join Date: Dec 2011
Posts: 2,568
In the garage:
Reputation: 0 ThunderMoose is on a distinguished road
Location: League City

United States




Default Re: Cranks but does not start

Quote:
Originally Posted by bmwe46nyc View Post
Lol....Gucci is slang for like perfect.....meaning that when I changed my air temp sensor under manifold and all of o2 sensors that solved my problem. But for me I think it was the o2 sensors.....


Sent from my iPhone using Tapatalk


O2 sensors are open loop for first little bit of operation. I wouldn’t think that this would prevent car from starting up. But not going to argue results.


Sent from my iPhone using Tapatalk
__________________


#67 2017 NASA TX TT3 Champion

FLMS Half Cage, RaceTech 4009HR drivers seat, Schroth 6-Pt Harness, E.S.S. Fire System, AIM SOLO DL with ECU Harness, SmartyCam, Angle Aluminum with VAC dead pedal, Sparco Steering Wheel on MOMO hub, MCS Suspension, Hyperco 800F 900R springs, Hotchkis Front and Rear Sway bars, Vorshlag Camber Plates, Turner ARCA, AJ Hartman Front Splitter, BW V2 Wing, BW CF Rear Diffuser, APEX ARC-8 wheels, Brembo BBK Front, Carbon Fiber Roof, CF Headlight Blanks, Door Windows and Cards Delete, TMS rear and front subframe reinforcement, Zionsville Competition Cooler, BW Oil Cooler, Oil Diverter Valve, Motorsports Thermostat, Evolve CF Intake, Epic Stepped Headers, Turner Pulleys, BW 3.5" Race Exhaust, EPIC Alpha N Tune, Beisan Oil Disk and Vanos Seals, ZF 5MT, CAE Ultra Shifter

My track journal: http://www.m3forum.net/m3forum/showthread.php?t=509148
Jump to top ThunderMoose is online now   Reply With Quote
Old Wed, Jan-09-2019, 01:54:43 PM   #19
berto
Registered User
 
Join Date: Jun 2011
Posts: 29
In the garage:
Reputation: 0 berto is on a distinguished road

United States




Default Re: Cranks but does not start

Ohh ok... lol ��
Jump to top berto is offline   Reply With Quote
Old Wed, Jan-09-2019, 06:41:44 PM   #20
jayyym3
Registered User
 
Join Date: Feb 2018
Posts: 34
Reputation: 0 jayyym3 is on a distinguished road

United States




Default Re: Cranks but does not start

Quote:
Originally Posted by berto View Post
hey whats Gucci ? and did the car start?
i am having a similar issue now also i am not getting any numbers on the gear display on the dash board so i am thinking its an SMG issue but i ran most diagnostics and checked most fuses i and cant seem to get it to start. its weird she even cranks without pressing on the break !!
You should hear the SMG pump prime when you unlock/open your car. I'm still able to switch between neutral and 1st gear. If yours isnt doing this then look into the salmon relay.
Jump to top jayyym3 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 02:45:27 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright ©1999-2017 M3Forum.com
Discussing Cranks but does not start in the E46 M3 (2001-2006) Forum - Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006. at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)