BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > BMW M3 Discussions > E46 M3 (2001-2006)
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All Albums Garage Search Today's Posts Mark Forums Read Calendar FAQ

E46 M3 (2001-2006) Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006.


Reply
 
Thread Tools Display Modes
Old Fri, Aug-31-2018, 10:51:24 PM   #971
M3jv909
Registered User
 
Join Date: Nov 2016
Age: 22
Posts: 56
Reputation: 0 M3jv909 is on a distinguished road

United States




Default Re: SMG troubleshooting FAQ

Could my slave cylinder be out? Just discovered this today, car doesn't start, leaked all pentosin out

Sent from my SM-G935T using Tapatalk
Jump to top M3jv909 is offline   Reply With Quote
Sponsored Links
Register now and remove these ads
Old Sat, Sep-01-2018, 06:47:35 AM   #972
zivagolee
@zivagolee
 
Join Date: May 2003
Posts: 363
Reputation: 0 zivagolee is on a distinguished road
Location: San Francisco

United States




Default Re: SMG troubleshooting FAQ

Quote:
Originally Posted by M3jv909 View Post
Could my slave cylinder be out? Just discovered this today, car doesn't start, leaked all pentosin out

Sent from my SM-G935T using Tapatalk

Maybe clutch actuator. If it's the part that's connected to the gear position sensor, then likely it.
__________________
2003 Orient Blue M3

https://www.instagram.com/zivagolee
Jump to top zivagolee is offline   Reply With Quote
Old Fri, Oct-26-2018, 10:23:11 PM   #973
ultimatemj
Registered User
 
Join Date: Dec 2008
Posts: 215
Reputation: 0 ultimatemj is on a distinguished road
Location: Chicagoland

United States




Default Re: SMG troubleshooting FAQ

Quote:
Originally Posted by M3jv909 View Post
Could my slave cylinder be out? Just discovered this today, car doesn't start, leaked all pentosin out

Sent from my SM-G935T using Tapatalk


Thatís what happened when my slave blew...


Sent from my iPhone using Tapatalk
__________________
2004 JB/Blk SMG | 2nd owner | Purchased Dec 2008 w/24k miles | Crossed over 100k mile Apr 2019
Key maintenance done @90k: Subframe reinforced | WPC Rod bearings | Beisan Vanos lockdown + chainguide
Refesh maintenance done: Suspension & Driveline rubber replaced | CSB | viton CPV | Coils + plugs+ O2s | Waterpump + Thermostat | Belts & pulleys
OE+ : Evolve airbox | Supersprint Exhaust | PE tune | CSL trunk | 18Ē VMR 710 w/PSS | EU OE 2pc Rotors | Koni+Dinan springs| Valentine1 w/StealthOne | Stereo build log
Jump to top ultimatemj is offline   Reply With Quote
Old Tue, Feb-05-2019, 04:38:06 PM   #974
Rickyrosh
Registered User
 
Join Date: Apr 2018
Age: 41
Posts: 81
Reputation: 0 Rickyrosh is on a distinguished road

United States




Default Re: SMG troubleshooting FAQ

Need some insight on this issue. Have not puled codes yet; plan to take it to my Indy shop tomorrow. This morning the SMG light (Amber) came on and car shifted a little slower into R and 1st, then when in 4th the revs would not go past 2k. Dropped it to 3rd and revs up fine to 3k. Didnít want to push it further since car was not up to temp. The car hadnít been started in a week. (04 conv with 116k, new clutch and flywheel 2k miles ago.)

Appreciate any inputs on the cause. Hope to drive slow in 3rd to Indy shop tomorrow.




Sent from my iPhone using Tapatalk
Jump to top Rickyrosh is offline   Reply With Quote
Old Thu, Feb-07-2019, 04:29:17 AM   #975
Da Jemster
Institutionalized User
 
Da Jemster's Avatar
 
Join Date: Jan 2007
Posts: 2,700
Reputation: 0 Da Jemster is a jewel in the rough
Location: Simi Valley

Philippines




Default Re: SMG troubleshooting FAQ

Could be losing pressure and that is why there is latency in shifting in addition to other issues. Until you get the codes, it would be difficult to ascertain what is failing.
__________________
....

2016 M235i - Black on Black

2008 E93 - AW - DCT - Stock...for now

2004 E46///CB-BLK///SMG II///D/A tuned///AFE Stg 2///SS Stepped///SS Metallic Cats///Eisenmann SS X-pipe///SS Race///4.10 diff///ACS CF Front Lip///6000K Xenons & Fogs///CF Grills & Gills///Angel Eyes///Clear Corners w/Solaris///Painted Reflectors///Black'd Sides & Tails///TEIN S
Jump to top Da Jemster is offline   Reply With Quote
Old Thu, Feb-07-2019, 09:57:00 PM   #976
Rickyrosh
Registered User
 
Join Date: Apr 2018
Age: 41
Posts: 81
Reputation: 0 Rickyrosh is on a distinguished road

United States




Default Re: SMG troubleshooting FAQ

Quote:
Originally Posted by Da Jemster View Post
Could be losing pressure and that is why there is latency in shifting in addition to other issues. Until you get the codes, it would be difficult to ascertain what is failing.


Code for position sensor P1848 and causes code P1756 to show up. Essentially car went into limp mode. SMG acting really weird - stays in N, restart car then able to shift to 1 and R, another restart wonít shift out of N. Pump and fluid are fine.


Sent from my iPhone using Tapatalk
Jump to top Rickyrosh is offline   Reply With Quote
Old Sun, Feb-10-2019, 03:03:56 AM   #977
Aeko
Registered User
 
Aeko's Avatar
 
Join Date: May 2018
Posts: 144
In the garage:
Reputation: 0 Aeko is on a distinguished road
Location: Houston

United States




Default Re: SMG troubleshooting FAQ

Any up to date links for the SMG.pdf file?
Jump to top Aeko is online now   Reply With Quote
Old Tue, Feb-12-2019, 04:36:01 PM   #978
IggyP
Registered User
 
Join Date: Oct 2018
Posts: 35
In the garage:
Reputation: 0 IggyP is on a distinguished road

United States




Default Re: SMG troubleshooting FAQ

2004 M3 with 120k miles.

I had an issue of my SMG dropping out of gear when it was supposed to be downshifting and SMG cog light would also light up with code P1717.
It would drop out of gear for 1 second, then go back in and I could continue driving like nothing ever happened.
I changed my relay and that didnt help. Next I checked the fluid level on the expansion tank right next to the intake manifold. I found that my fluid is low.
Realizing that it is obviously leaking somewhere, I saw that my pump is covered in the green Pentosin oil.
Upon further inspection the leak is coming from the house and fittings. It is known as the SMG hose. It goes from the expansion tank into the pump.

Since I topped off the fluid I dont have anymore dropping out of gear issues and I have not had any SMG lights on the dash.

I spent a lot of time researching what it could have been. From the temperature sensor, to the actuator, to the gear position sensor. My advice is to start from the lowest cost option and work your way up. My issue is leaking fluid and a $26 hose from BMW.

edit. My issues started when we had a week of -20 degree temperatures in Chicago area. I'm guessing old age and these crazy Hot + Cold temperatures here cracked all the old plastic pieces and ruined the o-rings.

Last edited by IggyP; Tue, Feb-12-2019 at 04:40:14 PM.
Jump to top IggyP is offline   Reply With Quote
Old Tue, Feb-12-2019, 05:31:03 PM   #979
brichter
Unregistered Abuser
 
brichter's Avatar
 
Join Date: Aug 2011
Posts: 873
In the garage:
Reputation: 0 brichter is on a distinguished road

United States




Default Re: SMG troubleshooting FAQ

I'd beg to differ with that, the best route is to diagnose the issue and then repair it. Throwing parts at any problem and hoping you luck into the repair at some point really isn't a cost effective way to fix anything.
__________________
2002 AW M3
Jump to top brichter is offline   Reply With Quote
Old Tue, Feb-12-2019, 06:06:40 PM   #980
IggyP
Registered User
 
Join Date: Oct 2018
Posts: 35
In the garage:
Reputation: 0 IggyP is on a distinguished road

United States




Default Re: SMG troubleshooting FAQ

Quote:
Originally Posted by brichter View Post
I'd beg to differ with that, the best route is to diagnose the issue and then repair it. Throwing parts at any problem and hoping you luck into the repair at some point really isn't a cost effective way to fix anything.
Not so easy to diagnose these SMG problems. I was convinced it would be the Gear position sensor for the longest time. I read the first 30 pages of this SMG troubleshooting thread and not a single person spoke about replacing this reservoir hose. Took some digging.
Jump to top IggyP is offline   Reply With Quote
Reply

Bookmarks

Tags
faq, smg, troubleshooting

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubleshooting Codes AirDoc E36 M3 (1992-1999) 0 Sat, Nov-17-2007 03:49:53 AM
Troubleshooting a problem ----> HELP ! RoadShreader E36 M3 (1992-1999) 43 Sun, Dec-31-2006 07:05:57 PM
Eclipse Troubleshooting crazy32184 E36 M3 (1992-1999) 7 Thu, Jun-09-2005 07:03:15 AM
HELP PLEASE!!! Troubleshooting my ///M! M3nEwBoOtY E36 M3 (1992-1999) 6 Sun, Apr-03-2005 04:37:52 PM



All times are GMT. The time now is 09:35:32 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright ©1999-2017 M3Forum.com
Discussing SMG troubleshooting FAQ in the E46 M3 (2001-2006) Forum - Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006. at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)