BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > BMW M3 Discussions > E46 M3 (2001-2006) > Coding and Tuning
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All Albums Garage Search Today's Posts Mark Forums Read Calendar FAQ

Coding and Tuning Discuss all avenues of coding and tuning here!


Reply
 
Thread Tools Display Modes
Old Thu, Apr-20-2017, 02:17:12 PM   #1
Obioban
Moderator
 
Obioban's Avatar
 
Join Date: Jul 2003
Posts: 36,582
In the garage:
Reputation: 54 Obioban has a spectacular aura about
Location: SE PA

United States




Default Warm up lights only functioning ~50% of the time

On my M3 wagon, the warm up lights on the tack only seem to function ~half the time. The rest of the time, the jump directly to 7500rpm orange (as if fully warmed up).

If relevant, I used Martin's tool to change to warmup values to those used on the CSL and enabled the SMG shift lights. I did this on pretty much day 1 with the car, so don't know if it did this stock or not-- I could check, if it's useful.

Thoughts?
__________________

Current Cars: 2005 IR/IR M3, 2001 LMB/blk M5, 03 530i, 04 M3 wagon, and some boring stuff
Past cars: 04 M3, 96 M3, S50B32 e36 M3 CM race car
Jump to top Obioban is offline   Reply With Quote
Sponsored Links
Register now and remove these ads
Old Thu, Apr-20-2017, 03:02:33 PM   #2
terraphantm
Moderator
 
Join Date: Dec 2010
Posts: 11,269
In the garage:
Reputation: 11 terraphantm is on a distinguished road
Location: Philadelphia

United States




Default Re: Warm up lights only functioning ~50% of the time

Flaky oil temp sensor maybe?
__________________
Jump to top terraphantm is offline   Reply With Quote
Old Thu, Apr-20-2017, 03:11:43 PM   #3
Obioban
Moderator
 
Obioban's Avatar
 
Join Date: Jul 2003
Posts: 36,582
In the garage:
Reputation: 54 Obioban has a spectacular aura about
Location: SE PA

United States




Default Re: Warm up lights only functioning ~50% of the time

Quote:
Originally Posted by terraphantm View Post
Flaky oil temp sensor maybe?
Oil temp on the oil temp gauge always reads as you'd expect (as in, it's full cold when the car is turned on, including the times when the warm up lights say it's fully warmed up).
__________________

Current Cars: 2005 IR/IR M3, 2001 LMB/blk M5, 03 530i, 04 M3 wagon, and some boring stuff
Past cars: 04 M3, 96 M3, S50B32 e36 M3 CM race car
Jump to top Obioban is offline   Reply With Quote
Old Thu, Apr-20-2017, 04:34:39 PM   #4
terraphantm
Moderator
 
Join Date: Dec 2010
Posts: 11,269
In the garage:
Reputation: 11 terraphantm is on a distinguished road
Location: Philadelphia

United States




Default Re: Warm up lights only functioning ~50% of the time

Quote:
Originally Posted by Obioban View Post
Oil temp on the oil temp gauge always reads as you'd expect (as in, it's full cold when the car is turned on, including the times when the warm up lights say it's fully warmed up).
Well the way the warmup lights are programmed, if the temperature reaches a threshold and then drops back down, the lights don't turn back on. So my thought is maybe if it's spiking quickly enough that it doesn't register on the gauge, the lights might stay off.

Not sure that's happening, but I don't remember having any similar issues on my car with any of the software variants I ran.
__________________
Jump to top terraphantm is offline   Reply With Quote
Old Fri, Apr-21-2017, 05:36:02 PM   #5
tr4ck_m3
Buildjournal
 
tr4ck_m3's Avatar
 
Join Date: Jun 2011
Posts: 1,887
In the garage:
Reputation: 0 tr4ck_m3 is on a distinguished road
Location: Irvine, CA

United States




Default Re: Warm up lights only functioning ~50% of the time

could be a bad cluster. I seen a couple of cars do that. But not sure 100% why
__________________
IG: @tr4ckM3
B-Spec Tune
2002 BMW E46 M3 6MT | B-Spec Tune + ProFlex Commander E70 315whp/242wtq
2013 BMW F30 335i 8AT | BM3 E30 Stg 2 Tune 367whp/457wtq
Jump to top tr4ck_m3 is offline   Reply With Quote
Old Fri, Apr-21-2017, 06:01:11 PM   #6
Obioban
Moderator
 
Obioban's Avatar
 
Join Date: Jul 2003
Posts: 36,582
In the garage:
Reputation: 54 Obioban has a spectacular aura about
Location: SE PA

United States




Default Re: Warm up lights only functioning ~50% of the time

Quote:
Originally Posted by terraphantm View Post
Well the way the warmup lights are programmed, if the temperature reaches a threshold and then drops back down, the lights don't turn back on.
Are you sure about that?

In my M3 coupe with CSL warmup values, driven in cold weather on the highway, I swear I've seen it drop back from 7500 to 7000...
__________________

Current Cars: 2005 IR/IR M3, 2001 LMB/blk M5, 03 530i, 04 M3 wagon, and some boring stuff
Past cars: 04 M3, 96 M3, S50B32 e36 M3 CM race car
Jump to top Obioban is offline   Reply With Quote
Old Sun, Apr-23-2017, 06:40:44 AM   #7
djjvr
OEM+
 
djjvr's Avatar
 
Join Date: Oct 2011
Posts: 2,094
In the garage:
Reputation: 0 djjvr is on a distinguished road
Location: Bay Area

Denmark




Default Re: Warm up lights only functioning ~50% of the time

I've seen the oil level sensor that resides in the pan cause an issue like that. Though usually you'll get the blinking yellow oil light at start up.
__________________
"I can't dance, but I can drive stick."

Build Journal Instagram
Jump to top djjvr is offline   Reply With Quote
Old Fri, Apr-28-2017, 01:00:40 AM   #8
Obioban
Moderator
 
Obioban's Avatar
 
Join Date: Jul 2003
Posts: 36,582
In the garage:
Reputation: 54 Obioban has a spectacular aura about
Location: SE PA

United States




Default Re: Warm up lights only functioning ~50% of the time

Quote:
Originally Posted by terraphantm View Post
Flaky oil temp sensor maybe?
This is feeling more likely-- the car just threw a code that read "thermal oil level sensor".
__________________

Current Cars: 2005 IR/IR M3, 2001 LMB/blk M5, 03 530i, 04 M3 wagon, and some boring stuff
Past cars: 04 M3, 96 M3, S50B32 e36 M3 CM race car
Jump to top Obioban is offline   Reply With Quote
Old Mon, Nov-05-2018, 12:53:51 AM   #9
MEV
Registered User
 
Join Date: Jul 2018
Posts: 2
In the garage:
Reputation: 0 MEV is on a distinguished road

Argentina




Default Re: Warm up lights only functioning ~50% of the time

Hey.
Probably this was already addressed, but I'm having similar symthomps, and in my case is because some times I have a stuck relay that doesn't turn off the ECU (an this also drains my battery).
If I leave turn on the car (2 position, not the engine), then turn off and wait for 10 seconds, then the ECU is off and when I try again, the lights are working as expected.

Max.
Jump to top MEV is offline   Reply With Quote
Old Mon, Nov-05-2018, 01:08:17 AM   #10
Obioban
Moderator
 
Obioban's Avatar
 
Join Date: Jul 2003
Posts: 36,582
In the garage:
Reputation: 54 Obioban has a spectacular aura about
Location: SE PA

United States




Default Re: Warm up lights only functioning ~50% of the time

Which relay?
__________________

Current Cars: 2005 IR/IR M3, 2001 LMB/blk M5, 03 530i, 04 M3 wagon, and some boring stuff
Past cars: 04 M3, 96 M3, S50B32 e36 M3 CM race car
Jump to top Obioban is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 07:01:49 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright 1999-2017 M3Forum.com
Discussing map switching in the Coding and Tuning Forum - Discuss all avenues of coding and tuning here! at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)