BMW M3 Forum
BMW M3 Forum BMW M3 Gallery BMW M3 Reviews BMW M3 Social Groups BMW M3 Chat M3Forum Sponsors >>
Loading


Mobile M3forum
Go Back   BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) > BMW M3 Discussions > E46 M3 (2001-2006)
Tire Rack Buy Winter Tires Now!
Not a member? Register Now!
Register Gallery All Albums Garage Search Today's Posts Mark Forums Read Calendar FAQ

E46 M3 (2001-2006) Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006.


Reply
 
Thread Tools Display Modes
Old Thu, Jul-05-2018, 02:29:16 PM   #1
quattrofrank
Registered User
 
Join Date: Jul 2017
Posts: 19
Reputation: 0 quattrofrank is on a distinguished road

United States




Default Car starts then stalls

Hi

This has happened to me a couple of times now. The car would work just fine then parked and started maybe 15min later. It will then start fine but die out.
First time it did this I cleared the adaptions and it started right away.
Now it just happened again and I only had my mobile with Carly innstalled.
Found a fault code: vanos b09 and I cleared that and it started right away again.

To me this seems like a electrical error since its fixed with clearing of adaptions / fault codes. But it seems very strange, I have searched and couldnt find any one with the same issue.

No engine light, the car has carbon airbox and alpha n ess tune.

Any suggestions?
Jump to top quattrofrank is online now   Reply With Quote
Sponsored Links
Register now and remove these ads
Old Thu, Jul-05-2018, 04:48:17 PM   #2
mrgizmo04
Registered User
 
mrgizmo04's Avatar
 
Join Date: Jan 2017
Posts: 2,467
In the garage:
Reputation: 0 mrgizmo04 is on a distinguished road
Location: Menlo Park

United States




Default Re: Car starts then stalls

Have you done any vanos related work recently?

This code can be caused by many vanos related items - broken hub tab, exhaust cam sensor, incorrect timing, solenoid...

Do some research on code 185.

Sent from my SM-G950U using Tapatalk
__________________
'85 528e 164k miles (sold)
'05 M3 6MT coupe

All DIY: 330 ZHP steering rack, diffsonline 4.1 diff with rem polish, E60 short shifter lever, AKG black diff bushings/subframe bushings, Rogue rtab, WPC rod bearings, Beyer driveshaft, full SS (SS stepped V1, catted S1, resonated S2, SS sport), Sachs clutch/flywheel, rear main, VANOS bullet proofing with anti-rattle, valve adjustment, cooling refresh, Ohlins R&T/Swift 448f 672r/GC street tops and camber plates, AFD E85 Proflex kit.

Happy to help with VANOS or any other DIY job around NorCal
Jump to top mrgizmo04 is online now   Reply With Quote
Old Thu, Jul-05-2018, 05:52:30 PM   #3
quattrofrank
Registered User
 
Join Date: Jul 2017
Posts: 19
Reputation: 0 quattrofrank is on a distinguished road

United States




Default Re: Car starts then stalls

Thanks for the tip, I will do some searching.
No I have not done anything with regards to the vanos but do you think those two are related (vanos fault code and the stalling?)
Jump to top quattrofrank is online now   Reply With Quote
Old Thu, Jul-05-2018, 05:56:48 PM   #4
mrgizmo04
Registered User
 
mrgizmo04's Avatar
 
Join Date: Jan 2017
Posts: 2,467
In the garage:
Reputation: 0 mrgizmo04 is on a distinguished road
Location: Menlo Park

United States




Default Re: Car starts then stalls

Quote:
Originally Posted by quattrofrank View Post
Thanks for the tip, I will do some searching.
No I have not done anything with regards to the vanos but do you think those two are related (vanos fault code and the stalling?)
Absolutely

Sent from my SM-G950U using Tapatalk
__________________
'85 528e 164k miles (sold)
'05 M3 6MT coupe

All DIY: 330 ZHP steering rack, diffsonline 4.1 diff with rem polish, E60 short shifter lever, AKG black diff bushings/subframe bushings, Rogue rtab, WPC rod bearings, Beyer driveshaft, full SS (SS stepped V1, catted S1, resonated S2, SS sport), Sachs clutch/flywheel, rear main, VANOS bullet proofing with anti-rattle, valve adjustment, cooling refresh, Ohlins R&T/Swift 448f 672r/GC street tops and camber plates, AFD E85 Proflex kit.

Happy to help with VANOS or any other DIY job around NorCal
Jump to top mrgizmo04 is online now   Reply With Quote
Old Thu, Jul-05-2018, 10:23:08 PM   #5
jackzasiewski
Registered User
 
jackzasiewski's Avatar
 
Join Date: Jun 2015
Age: 51
Posts: 13
Reputation: 0 jackzasiewski is on a distinguished road

United States




Default Re: Car starts then stalls

Quote:
Originally Posted by quattrofrank View Post
Hi

This has happened to me a couple of times now. The car would work just fine then parked and started maybe 15min later. It will then start fine but die out.
First time it did this I cleared the adaptions and it started right away.
Now it just happened again and I only had my mobile with Carly innstalled.
Found a fault code: vanos b09 and I cleared that and it started right away again.

To me this seems like a electrical error since its fixed with clearing of adaptions / fault codes. But it seems very strange, I have searched and couldnt find any one with the same issue.

No engine light, the car has carbon airbox and alpha n ess tune.

Any suggestions?
I don't think vanos problem - unless severe - would cause stalling.
I suspect mass airflow sensor or a crankshaft sensor. MAF will generate fault codes - probably - crankshaft can cause stalling with no codes

Sent from my LG-H933 using Tapatalk
Jump to top jackzasiewski is offline   Reply With Quote
Old Thu, Jul-05-2018, 10:36:04 PM   #6
quattrofrank
Registered User
 
Join Date: Jul 2017
Posts: 19
Reputation: 0 quattrofrank is on a distinguished road

United States




Default Re: Car starts then stalls

I have alpha n so no air mass sensor.
But cam sensor is a good tip
Jump to top quattrofrank is online now   Reply With Quote
Old Thu, Jul-05-2018, 11:43:45 PM   #7
mrgizmo04
Registered User
 
mrgizmo04's Avatar
 
Join Date: Jan 2017
Posts: 2,467
In the garage:
Reputation: 0 mrgizmo04 is on a distinguished road
Location: Menlo Park

United States




Default Re: Car starts then stalls

Code b09 is a specific vanos code for exhaust side (it is also decimal code 185).

In post 2 I list some of the items that could be causing it, one of which is the exhaust side cam sensor. If the dme doesn't know what position the cam is in, it can cause it to run poorly and stall.

Vanos is more than just solenoid or hub tabs or cam bolts taken in isolation, there is a lot more at play that the system relies on for proper signal.

Sent from my SM-G950U using Tapatalk
__________________
'85 528e 164k miles (sold)
'05 M3 6MT coupe

All DIY: 330 ZHP steering rack, diffsonline 4.1 diff with rem polish, E60 short shifter lever, AKG black diff bushings/subframe bushings, Rogue rtab, WPC rod bearings, Beyer driveshaft, full SS (SS stepped V1, catted S1, resonated S2, SS sport), Sachs clutch/flywheel, rear main, VANOS bullet proofing with anti-rattle, valve adjustment, cooling refresh, Ohlins R&T/Swift 448f 672r/GC street tops and camber plates, AFD E85 Proflex kit.

Happy to help with VANOS or any other DIY job around NorCal
Jump to top mrgizmo04 is online now   Reply With Quote
Old Fri, Jul-06-2018, 11:29:41 AM   #8
quattrofrank
Registered User
 
Join Date: Jul 2017
Posts: 19
Reputation: 0 quattrofrank is on a distinguished road

United States




Default Re: Car starts then stalls

I did some more fault finding.
The b9 code shows up immideatly when idling.
According to beisian procedure this could be either the exhaust hub tabs for the pump or the solenoid.
Took of the cam cover and inspected, the tabs are fine.
Then its safe to assume:
1. exhaust cam sensor or
2. solenoid

Have I understand correctly?
Jump to top quattrofrank is online now   Reply With Quote
Old Thu, Jul-12-2018, 01:17:37 PM   #9
quattrofrank
Registered User
 
Join Date: Jul 2017
Posts: 19
Reputation: 0 quattrofrank is on a distinguished road

United States




Default Re: Car starts then stalls

So today I have changed:
exhaust cam sensor (new oem)
Solenoid (new oem)
Cleared fault code and the b9 code immideatly shows up when car is idling.

what could be the issue now?
Jump to top quattrofrank is online now   Reply With Quote
Old Thu, Jul-12-2018, 01:23:53 PM   #10
WuBai
Five Spiced and Lovin' It
 
WuBai's Avatar
 
Join Date: Jan 2009
Posts: 489
Reputation: 0 WuBai has disabled reputation

United States




Default Re: Car starts then stalls

Very far from the area you are looking at currently, but it’s worth an ask: how old is your fuel pump? They tend to fail intermittently and allow the car to start then stall quickly afterwards if they are on their last leg.
Jump to top WuBai is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 11:40:48 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
M3Forum.com and M3forum.net is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW and M3 (E90 M3 | E92 M3 | E93 M3 | E46 M3 | E36 M3 | E30 M3) are registered trademarks of BMW AG.
M3Forum Terms of Service
Copyright 1999-2017 M3Forum.com
Discussing Car starts then stalls in the E46 M3 (2001-2006) Forum - Engine: S54 - Max Hp: 333 hp at 7,900 rpm / 262 lb/ft at 4,900 rpm
Total Produced: 45,000+ - Years Produced: 2001 to 2006. at BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)