View Single Post
Old Tue, Oct-04-2011, 11:43:40 PM   #1
Jrrrrrrr
Unregistered User
 
Jrrrrrrr's Avatar
 
Join Date: Jun 2011
Posts: 789
In the garage:
Reputation: 0 Jrrrrrrr is on a distinguished road
Location: Tucson, AZ

United States




Default Vapor Trails: code FD, evap valve stuck closed

UPDATE

I managed to find a semi-permanent, easy, and cheap solution to this problem. Skip to THIS POST if you are just looking for the solution.

There are some valuable documents that can help you with diagnosing this and other OBD-2 fuel evaporative issues in THIS POST


ORIGINAL POST

For the past several weeks I have been dealing with a regular CEL and accompanying Peake "FD" code. In case one doesn't know, that code states that the evaporative purge valve on the charcoal canister housing is stuck closed. Needless to say, I am sick of resetting the CEL every 2 drive cycles, but can't shake it off.

Facts:
1. It comes back every second run cycle (start engine, drive, shutoff engine) when that run cycle involves at least a short trip on the freeway (5th gear).
2. When I am only driving around town, it can take a number of run cycles to reappear (4-6).
3. If I ignore it, the code and CEL will go away after several run cycles, but always returns within several more run cycles.
4. Both the original purge valve and the replacement I got ARE NOT stuck closed and open smoothly with 12v applied across the terminals. They also close when 12v is taken away.

What I have tried so far:
1. Replacing the valve (no joy).
2. Applying 12v across the terminals of both valves -- the plunger inside both valves open and close fine.
3. Lubing the original valve with WD-40 -- no apparent difference in its operation.
4. Testing for continuity between the ground wire on the valves harness plug and the DME terminal specified by the Bentley -- good continuity.
5. Testing for 12v at the harness plug. As per the Bentley, the valve is normally closed and should open in pulses when the DME allows it to ground. I set up a multimeter apparatus and watched the voltage while I was driving. In fact, there is varying voltage going to the harness plug.

Some random post at BFC references a BMW order that this problem is known and is caused by a too-low voltage threshold in the DME. The alleged fix is to go to the dealer and have the DME software updated. I'm skeptical because I didn't have this problem at all for the first several months I owned the car. I also don't want to dump exorbitant amounts of money at the dealer for a "fix" that no one has confirmed the effectiveness of -- and that's if the service guy doesn't just laugh at me like I have a penis growing out of my forehead.

Who has actually solved this problem? Is there any other possible silly thing I might be overlooking?

Last edited by Jrrrrrrr; Sat, Jun-17-2017 at 05:36:52 PM.
Jump to top Jrrrrrrr is offline   Reply With Quote
Sponsored Links
Register now and remove these ads