BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X)

BMW M3 Forum.com (E30 M3 | E36 M3 | E46 M3 | E92 M3 | F80/X) (http://www.m3forum.net/m3forum/index.php)
-   E90 M3 (Sedan) | E92 M3 (Coupe) | E93 M3 (Convertible) (2008-2013) (http://www.m3forum.net/m3forum/forumdisplay.php?f=69)
-   -   CIC / Nav System Failure - Tips and Tricks? Part Number? Coding? Afternarket Upgrades (http://www.m3forum.net/m3forum/showthread.php?t=611009)

irex511 Fri, Nov-08-2019 12:22:16 AM

CIC / Nav System Failure - Tips and Tricks? Part Number? Coding? Afternarket Upgrades
 
Hey Folks,

I have a 2011 M3 and the infotainment system is rebooting every 30 seconds or so. I've done enough searching to know that it looks like my CIC computer needs to be replaced, but I have a few questions:

1) Anything else I should try before shelling out the cash? I've reset the system, disconnected the battery, etc.

2) Anyone have the part number for the CIC computer for this car? I find a bunch of stuff on eBay and re-sellers for doing the swap that comes with the screen, but I really don't need that.

3) Some people say that when you do a swap from the older systems, it takes the dealer to code them to the car. I'm assuming I'll have the same challenge with a straight up swap? Does anyone know if someone has figured out a DIY for this?

4) Any aftermarket systems worth upgrading to while doing this? Assuming no from some light digging but thought I would ask.

Thanks for the help!

Milehighredm3 Mon, Nov-18-2019 04:40:19 PM

Re: CIC / Nav System Failure - Tips and Tricks? Part Number? Coding? Afternarket Upgr
 
I had a similar issue, I bought one from a year new salvage for $200. Works great other than the Nav does work. BMW says they a VIN locked, they were surprised it worked at all. So I will be eventually pay out the $1200 for a new one, Should be part # at tis link http://bmwfans.info/parts-catalog/E9..._computer_mid/

irex511 Mon, Jan-13-2020 01:56:52 AM

Re: CIC / Nav System Failure - Tips and Tricks? Part Number? Coding? Afternarket Upgr
 
Thanks for the info. Just to close out the thread, I found another post that implied that it might be hard drive failure that causes this issue, so decided to check it out.

I removed my hard drive (and made a how-to video
), and found that though the navigation didn't show back up, the boot loop stopped happening.

I was then able to follow this thread on e90 post to upgrade my drive to an SSD, resolving the problem:
https://www.e90post.com/forums/showthread.php?t=1426773

Hope this helps someone!


All times are GMT. The time now is 05:00:26 AM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright 1999-2017 M3Forum.com