Web www.M3Forum.net

View Full Version : ICELink sound quality..


Malibu101481
Sat, Jan-22-2005, 08:16:34 PM
Okay so.... got the Icelink in last night after reading a DIY thread @ e46fanatics... it works GREAT!!! :beer:


However, on the way home from the club last night i really wanted to crank it up and i noticed that the sound is ALL distorded!!! :banghead: my EQ is off on the ipod so it can't be that, any of you guys have this issue.... :hmm: it almost sounds like the ipod is not getting enough power....????? i dunno :nixweiss:

skibuf8
Sat, Jan-22-2005, 09:22:23 PM
The info on this site made a huge difference in terms of sound quality for my pod. In fact, I use a car adapter right now and after using mp3gain/eupod I only have to use about 50% volume on my stereo compared to before. Check it out. http://www.dapreview.net/content.php?article.133

DensionUSA
Mon, Jan-24-2005, 05:57:05 PM
Okay so.... got the Icelink in last night after reading a DIY thread @ e46fanatics... it works GREAT!!! :beer:


However, on the way home from the club last night i really wanted to crank it up and i noticed that the sound is ALL distorded!!! :banghead: my EQ is off on the ipod so it can't be that, any of you guys have this issue.... :hmm: it almost sounds like the ipod is not getting enough power....????? i dunno :nixweiss:

You will need to verify the gain is set at 2v - it seems you have it set @ 4v. This can be found by pressing Button #6 on your head unit and going to the ice>Link Plus setup menu.