Web www.M3Forum.net

View Full Version : Orange Sequential M Gearbox with Drivelogic light.


M Powered
Fri, Jan-21-2005, 12:34:58 AM
Far right orange warning lamp ( Sequential M Gearbox with Drivelogic light).
I Was driving tonight light came on (was not Flashing). Owners manual says take it in to get looked at because there is a malfunction in the system. After the car was turned off and re-started light went out and did not come back on. Car only has 5,000 miles, just curious if anyone else has had this problem. If anyone has had a problem with this does the dealer just reset the drivelogic software? What's going on? Will call the dealer tomorrow.

gnk2727
Fri, Jan-21-2005, 12:38:09 AM
This has happened to me before. I did not take my car into the dealer, but you may want to.

FYI: I was pressing the gas and the brake at the same time, so that's why mine went off. I'm not sure what you were doing.

Euphoria///M
Fri, Jan-21-2005, 01:11:04 AM
It shouldn't be anything if the light didn't come back. If it does, give a visit to the stealer.

GHOSTRIDER
Fri, Jan-21-2005, 02:21:08 AM
Check your hood. Make sure it is shut properly. Mine went off on my '02 last year and it was the hood sensor. Replaced under warranty.

///
Sat, May-05-2007, 11:47:44 PM
i dug this out of the archive. this also happenned to me today. any other opinions? should i take it in?

John_T
Sat, May-05-2007, 11:53:02 PM
i dug this out of the archive. this also happenned to me today. any other opinions? should i take it in?
If you have checked through all the possibilities already mentioned in the this thread and it is still happening, then maybe it's a good idea to bring it in instead of.....:banghead: :banghead:

///
Sun, May-06-2007, 12:23:02 AM
i know i know. it happenned earlier today on my way home. i was about to call the dealership, but i found this thread. i went back and started the car again, and the light went off upon ignition. so now after 3 more drives, the light remains off. i'm leaning towards not taking it in because i can't hear or feel anything unusual about the smg...i was wondering if there was anybody that did not take it in and later regretted it. thanks

j&pse6m3
Sun, May-06-2007, 05:02:22 AM
I have had this problem on my car. It first locked and after messing around(turning the ignition on/off and placing it in and out of neutral) I got it to start. A few days later it locked completely. Towed to the dealer and after a couple of hours it was fixed. They told me it was a problem with a sensor in the gearbox. No joke 3 days later it went out again. Turns out it was a problem with a spring or something in the gearbox. It happened about a year ago so I can't quite remember, but the mechanic is very familier with this problem because it is fairly common. I think you sould get it checked, you might get stuck somewhere. Just tell them to dig deeper so you don't have to go back.

jerrym
Sun, May-06-2007, 05:08:53 AM
... maybe if driving smg wasnt as similar as automatic?
:x you wouldnt have the drive-logic turn on

///
Sun, May-06-2007, 06:21:01 AM
... maybe if driving smg wasnt as similar as automatic?
:x you wouldnt have the drive-logic turn on

what?

WillC310
Sun, May-06-2007, 06:39:17 AM
I would take it in now and see if they can pull a fault code. It's best to get this documented now incase it becomes a bigger problem down the road..